How to add thousands separator in Survey123?

466
5
11-09-2021 07:37 AM
LeandroBenicio_de_Souza
New Contributor II
How to add thousands separator in Survey123? I used "thousands-sep" in the appearance column. On Survey123 Connect it works, but when I publish it doesn't work.
Attached are 2 images of the problem, one in survey123 Connect and another from the published form.

 

0 Kudos
5 Replies
Philip-Wilson
Esri Notable Contributor

Hi @LeandroBenicio_de_Souza,

The thousand-sep appearance is currently only supported in Connect and the field app, it is not supported in the web app. Looking at your screenshots, it appears you are trying to use the survey in the web app.

We have an issue in our backlog to support this in the future, for now we will add a note to the documentation, to say it is not supported in the web app.

https://doc.arcgis.com/en/survey123/desktop/create-surveys/xlsformsappearance.htm#ESRI_SECTION1_7A95...

Regards,

Phil.

LeandroBenicio_de_Souza
New Contributor II
Thanks for the answer.
Yes I am using the web app.
Is there another option to add the thousands separator in the web app?
0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @LeandroBenicio_de_Souza,

The thousands separator in the web app is currently controlled by the locale of survey, the locale of the signed in user, or the locale of the browser/device. 

What locale are you using? Do you see different outcome if you use different locales?

Regards,

Phil.

0 Kudos
LeandroBenicio_de_Souza
New Contributor II
I'm from Brazil.
The form will be public and will be used by city halls of the State of Paraná
0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @LeandroBenicio_de_Souza,

What locale format is your ArcGIS account set to, and your device and browser? Do you use multi language surveys and set the locale in the XLSForm?

If you are in Brazil, assume you are using pt_BR locale? If so you use comma for decimal point, and point for thousand seperator. This may be the issue with web app that the locale formatting is not being applied correctly based on your ArcGIS user account settings or browser settings?

Regards,

Phil.

0 Kudos