Hosted Feature Layer View from Join does not show on Survey123 Connector/App Map

588
1
Jump to solution
01-17-2023 02:47 PM
JJ_Reyes
Occasional Contributor

GOAL: display realtime symbology from latest inspection record at a location. For example, I want the location to turn orange when Field 1 from inspection related table is complete, and green when Field 2 from inspection related table is complete.

Observed problem: Custom webmap used as default in Survey123 does not show data points when hosted feature layer view created from JOIN is used. Data is displayed appropriately when viewing same webmap on AGOL.

Step 1: Create hosted feature layer view from the layer my survey uses.

  • The view is a join of a parent and child table, so that all parent fields PLUS all the fields from the last record of the child are included as one record in this view.
  • The view can't be edited because it is created from an attribute JOIN that updates dynamically

Step 2: Add hosted feature layer to Survey123 webmap

  • WORKING: In AGOL, the field used for symbology (from the latest inspection record) is showing real time updates

Step 3: Change basemap in Survey123 Connector to use webmap

  • NOT Working: well locations are no longer displayed. What I am able to see in the webmap, is not displaying in Survey123 Connector Map options or in Survey123 itself

Other ideas: use featureset...but this is noted not to work for real time updates

Is this a know limitation or is there some gotcha I have missed?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JJ_Reyes
Occasional Contributor

This was apparently a bug in my web map. I got this to work by creating a new webmap. 

View solution in original post

0 Kudos
1 Reply
JJ_Reyes
Occasional Contributor

This was apparently a bug in my web map. I got this to work by creating a new webmap. 

0 Kudos