hiding survey section with default answers

714
7
12-06-2020 02:47 PM
chiragtiwari
New Contributor II

Dear Colleagues at the end of the survey i have created i have a QC/QA system that i want to hide from the surveyor.  This section has two default answers added to it.  But when I use ${platform}='z' in the relevant column to hide the entire group I lose the default answers.  

When I remove the ${platform}='z' the default answers populate in the survey form.  Can i please get some assistance?

0 Kudos
7 Replies
Philip-Wilson
Esri Notable Contributor

Hi @chiragtiwari 

When a question is not relevant, it can not have an answer, not data is submitted for not relevant questions. That is why you do not see your default answers for these questions once submitted.

You could use a "hidden" or "calculation" question type instead. These are questions that are always hidden from the form but have the answers saved behind the scenes. Or you could use the new "hidden" appearance on any question type to hide the question from the form, but if it is still relevant then it can still have a valid answer just it will not be displayed to the user.

Also, instead of using the "default" column, consider using the "calculation" column, especially if you still plan to use relevant on the same questions, as defaults will only load once when the form first opens, but calculations will continue to be applied after form load, even if the relevance of a question changes. 

Regards,

Phil.

0 Kudos
chiragtiwari
New Contributor II

Hi Phil can you show me how to use the calculation field to resolve this issue?

0 Kudos
Philip-Wilson
Esri Notable Contributor

Can you provide a copy of your xlsx file, so I can take a closer look and see the best way to modify it to obtain the outcome you are after?

Phil.

0 Kudos
chiragtiwari
New Contributor II

Dear Philip,

Here is the section of the survey in question.

0 Kudos
IsmaelChivite
Esri Notable Contributor

Like @Philip-Wilson anticipated, using the hidden appearance looks like the best choice here. If you also apply a relevant statement, the question values will be set to null if the relevant expression evaluates to false.

IsmaelChivite_0-1607360760014.png

 

chiragtiwari
New Contributor II

Hi Ismael,

 

I selected hidden in the appearance field but it doesn't do anything.  Can you please advise.

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @chiragtiwari ,

What version of Survey123 Connect and the field app are you using? You need to be using the latest 3.11 release of both applications for hidden appearance to work.

Regards,

Phil.

0 Kudos