Getting MSL with Trimble Catalyst in Survey123

683
3
08-26-2020 11:49 PM
RimaRabinovich
Esri Contributor

Hello,

Our client is familiar with the option to work with Trimble Catalyst in Collector for arcgis,

They want to work with Trimble Catalyst in Survey123, the problem is - they can't get the MSL.

They use Trimble Mobile Manager , we can see that in the TMM app there are two values for altitude - HAE and MSL.

but they always get HAE.

they set the altitude type in the survey app to MSL - but it is not working.

*They are working with android.

later we found out in the log file of TMM , that it's output includes only HAE (no MSL or geoid separation).

the NMEAL Log file is attached.

Product Configuration Guide | Trimble Geospatial 

I have oppened a support case about this issue 3 month ago in may 2020..but we didn't get a solution.

Is there a way to get MSL in survey 123 with Trimble Catalyst?

James Tedrick

Marika Vertzonis

Thank you,

Rima

0 Kudos
3 Replies
BrettStokes
Esri Contributor

Hello Rima,

I've been able to get hold of a Trimble Catalyst for testing and have an idea of what might be causing this limitation. Unfortunately, I only have the free subscription which is not even showing MSL in the Trimble Mobile Manager app.

I believe the TMM app (with paid subscription) is just calculating the geoid separation on the fly and applying it to the HAE to get the MSL. Since Survey123 can only utilize the Trimble Catalyst position through the TMM app (setting it as the mock location provider - and therefore not getting all the metadata) I'm not sure if the device calculated geoid separation is coming through to Survey123 at all.

Could you please test this out with your Sub-meter Catalyst subscription using a simple survey and, for example: pulldata("@geopoint",${location},"geoidSeparation") to see if any non-zero geoid separation values are being reported by the device? If values are being reported, then there is an issue with the way Survey123 is handling them, however I suspect the values are simply not making it through to the app due to the mock location provider setup.

Thanks,

Brett

0 Kudos
jmmGeoToo
New Contributor II

Hi all. On behalf of Trimble, I'll work with Esri Melbourne to figure this out. 

0 Kudos
Hegik
by
New Contributor II

Hello everyone!

I think this is a common problem for people trying to get the MSL out of Field Maps, Collector or Survey123.

I talked about it here:

Measure the orthometric height in Field Maps - Esri Community

I think at the moment there are only postprocessing workarounds available.

0 Kudos