First Page Repeats after clicking Next on Web App Only

248
8
Jump to solution
12-21-2021 10:01 AM
KarimNaguib
New Contributor III

Good morning.

I am working on a fairly straight forward survey to track vehicle time.  The survey is basically made up of 3 pages.

Page 1: has the employee information.  I'm using pick lists, and pulling data from the Choices sheet as well as from an external CSV.  This should be a 1:1 relationship where 1 employee is assigned 1 vehicle, and also all of the information provided here will be valid for all entries on the other pages.

Page 2: This is a bit more complicated.  Users enter the project information and equipment used/hours used.  The user can enter multiple projects (so that is a repeat), and multiple vehicles per project (a repeat nested within the projects repeat).  This all seems to be working just fine.

Page 3: This just shows the total hours submitted as a read only, and provides the user a place to sign off on the hours.  This is simple, and also works just fine.

The issue I am having is on Page 1.  In the web app, after filling out page 1, and clicking "Next", page 1 shows up again, completely filled in.  If I hit "Next" again, it moves onto page 2.  There is no repeat on this page, and everything else seems to work fine after clicking "Next" for a 2nd time.  This behavior is not consistent across apps either.  In Connect 3.13.251, and in Survey123 Field App 3.13.244 it works as expected, so the only place I've been able to reproduce the issue is in the Web App using either Chrome or Edge.

I've attached scrubbed xlxs, and csv used in the survey.  Any insight into a resolution would be greatly appreciated.

Thanks,
Karim

0 Kudos
1 Solution

Accepted Solutions
Ruth_JiatengXu
Esri Contributor

Hi @KarimNaguib 

Here is the form I published, and it looks like the following:

user.gif

Could you please help double-check your form? 

1. All questions except generated_note_ should be wrapped in group or repeat with field-list appearance

2. Change the name of your note question "Use to track ..." to something else.

Or could please you share your XLSForm with us, then I can help you check.

Thanks for your patience!

Bests,

Ruth

View solution in original post

8 Replies
Philip-Wilson
Esri Notable Contributor

Hi @KarimNaguib,

I just published your survey and was doing some testing, and can see the issue. There should only be 3 pages based on your survey design (there are 3 field-list groups/repeats). However the web app is displaying 4 pages when first opened, which breaks the form navigation between page 1 to 2. Nothing look obvious in the XLSForm as to what would cause this to occur.

Are you still having this issue, noting this post is a few weeks old, or did you resolve it? I have asked our website developers to take a look, and we will get back to you with any further information.

Regards,

Phil.

0 Kudos
KarimNaguib
New Contributor III

I wasn't able to resolve it, and it sounds like it is a known issue.  The problem, normally, happens when there is a note field following an image, however, I believe I removed all of the images but the problem persists.  Fortunately, it is only on the web form, so I am just forcing users to use the app instead.

BUG-000139401 : In survey123 web form, when a note type question with image attached is placed above a group, it ends up creating a duplicate page.


Thanks Phil.

Ruth_JiatengXu
Esri Contributor

Hi @KarimNaguib ,

I modified your XLSForm a little bit, and this should make your form works as expected in the web app.

I wrapped the generated_note_surveyDescription question in a group with field-list appearance (I highlighted the places I edited). The web app always rendered the generated_note_surveyDescription question as a separate cover page for the multiple-page survey, so it should be wrapped in a field-list group for the multiple-page survey.

I guess your survey is published from the website as a single-page survey, so the generated_note_surveyDescription question does not work as expected.

Please let me know if you have any other questions!

Thanks,

Ruth

0 Kudos
KarimNaguib
New Contributor III

Thanks Ruth,

I tried to update my form based on the changes you suggested.  That does create a 4th page (was not my intent), but thank you.  I did also note that when the I tried to publish, I got an error because there was no label on the Begin Note field.

Thanks again for taking another look.

Karim

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi @KarimNaguib 

Thanks for your reply! If you don't want to see the description on a separate page, please change the name of your survey description to something that is not "generated_note_surveyDescription", and move the note question into your first page group. Then the survey description will be rendered as a normal note question instead of the survey description. I have attached another modified form here, please ignore the warning "question has no label", and it is ok for the page to have no label. (We can skip warnings but not errors).

To make it more clear, it is the by-design behavior of the web app to display the survey description (generated_note_surveyDescription note question) as a separate page. If you still need to have a survey description and you want to see it together with your first page content, please let me know.

Thanks,

Ruth

KarimNaguib
New Contributor III

Thank you Ruth.  I just tried the form that you sent, and on the web form I ended up with a 6 page survey rather than a 3 page survey.  It ended up creating a new page for each of questions on the first page (on the web form only).

Thanks,
Karim

KarimNaguib_0-1643298384948.png

 

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi @KarimNaguib 

Here is the form I published, and it looks like the following:

user.gif

Could you please help double-check your form? 

1. All questions except generated_note_ should be wrapped in group or repeat with field-list appearance

2. Change the name of your note question "Use to track ..." to something else.

Or could please you share your XLSForm with us, then I can help you check.

Thanks for your patience!

Bests,

Ruth

KarimNaguib
New Contributor III

Thank you Ruth.  I have changed the survey quite a bit since I first posted, but it does seem like these changes will resolve the issue.  Thank you for taking the time to respond.