Feature Report not properly sizing photos

595
5
07-19-2019 03:53 PM
AdamInglis1
Occasional Contributor

I'm having trouble getting the Feature Report to properly size the photos.  I'm trying to fit two photos per page so I've restricted the width to 500, and maintained the aspect ratio using this syntax:

${ photo | size:500:0}

However, the output Feature Report seems to be reserving a ton of white space at the top and the bottom of the photos which only allows for one photo per page.  Did something change when the new site was launched that might be causing this?

5 Replies
JodyZhengLiu
Esri Contributor

Hi Adam,

Thanks for your feedback, but I can't reproduce it with a single repeat for photos in my test survey. Is it possible to share you survey xlsx file and a sample photo to zliu@esri.com? Thanks a lot!

Best,

Jody Zheng Liu

0 Kudos
JodyZhengLiu
Esri Contributor

Hi Adam,

Thanks for sharing the files. The reason why you have white spaces is because the "appearance" column of the image questions in xlsx form is set to "annotate", which will capture the whole device screen and upload that as the image. This is useful when you want to add annotations (drawings, text watermarks etc.), but if you don't need to add any annotations then just delete the annotate appearance and this will upload the original image files. 

Thanks,

Jody Zheng Liu

0 Kudos
AdamInglis1
Occasional Contributor

Hi Jody, 

Thanks for the information, I was unaware that adding the annotate option caused the entire screen to be captured.   I wish there was a way to restrict the annotation to just the photo size as it is a nice option to have, although rarely used by our field crews.  

I guess nothing can be done to correct reports that have already been submitted with the annotate appearance, removing this option will just effect future submissions, is that correct?

Regards, 

Adam

0 Kudos
JodyZhengLiu
Esri Contributor

Hi Adam,

Thanks a lot for the suggestion, and yes, changing the appearance will only effect future submissions. One work-around is to edit the submitted records(delete and resubmit images) using the Survey123 web app, with the edit mode(append ?mode=edit&objectId= in the URL of your survey) described in this post: https://community.esri.com/groups/survey123/blog/2019/05/24/survey123-tricks-of-the-trade-editing-re...

Thanks,

Jody Zheng Liu

0 Kudos
MichaelAshelford
New Contributor II

Hi all, 
Has there been any progress/update on this? It seems like a bit of an oversight - one would only annotate photos to produce them in a feature report, but they all are produced with the white background. Perhaps there is a way to limit the 'capture' to the size of the photo? I notice that the white is present in field app. Maybe the photo size can be matched to the capture size? If this can happen I have no idea how :) 

0 Kudos