Select to view content in your preferred language

Error converting XLSForm - Survey123 Connect 3.14 version

5081
23
Jump to solution
03-23-2022 09:48 AM
AdriannaBarton
New Contributor III

Beginning this morning we have been getting this error, "Error converting XLSForm" when saving an .xls form. It is happening when a field is moved, deleted, or a calculation is incorrect, and pretty much any time we don't save after making a small change. Typically where a detailed error used to be given it is just this message. Is anyone else having this issue today? We have 3.14 desktop connect, which we have been using for weeks so no new download on our end. 

23 Replies
HillaryMarler
New Contributor II

I'm also still having this issue, even after uninstalling, then re-installing.

0 Kudos
IsmaelChivite
Esri Notable Contributor

Hi. This is likely caused by a problem in the XLSForm validation web service. Looking into this.

JevitaWebster
New Contributor III

I'm having the same problem. i'm using Ver 3.14.256. This started last week, i created two surveys and one im having this problem with. @IsmaelChivite  have you found and on the XLSForm validation web service ?

0 Kudos
IsmaelChivite
Esri Notable Contributor

Confirming that the issue sits in the Survey123 XLSForm validation web service. This is why this is affecting all versions of Survey123 Connect. The team is working to publish a fix as soon as possible. Doing our best to get this resolved before Tuesday.

 

Update March 20, 2022. The fix is now in production

Katie_Clark
MVP Regular Contributor

Thanks Ismael! I know these bugs are frustrating for everyone, but we appreciate your hard work!

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
LeonardBarnhill
Occasional Contributor

I also appreciate the team's efforts to resolve problems as they occur in a product that has an update every month-ish.  I was able to confirm that the problem is affecting version 3.13. and 3.14.  I does not seem to matter if the XLSForm was created in 3.13 or 3.14 or whether you are using Connect version 3.13 or 3.14 - I have tried all combinations of this with no resolution to the problem.  

0 Kudos
CandaceHankins
New Contributor II

@IsmaelChivite Do you have an update on this issue?

FrankMancini
New Contributor III

Running into this issue after updating an on-site installation of the Survey123 Website and Connect.

ArcGIS Enterprise 10.6.1
Survey123 Website 3.14.34
Survey123 Connect 3.14.281

 

Was the fix pushed into the on-prem ArcGIS Survey123 v3.14 Website Installer? Or is there a hotfix available?

0 Kudos
HuntingtonHabitatLuz
New Contributor

Buenas tardes, desde ayer jueves en la tarde me da ese mismo problema

0 Kudos
IsmaelChivite
Esri Notable Contributor