Error 401 when trying to publish a survey

83
4
07-25-2019 12:59 PM
Highlighted
New Contributor II

I am trying to publish a survey and get the following message/error each time. The folder gets created in arcgis, the feature layer gets created, but the form does not transfer over into the folder. I have gone into arcgis and deleted the folder and tried a few more times (because if I don't I get an error sooner saying the folder cannot be created). This is not the first survey I have published but I cannot figure out what is going on; I have about 20 surveys to create but I don't want to make all of the templates and not be able to transfer them from Survey123 Connect to being published.. Any help would be appreciated. 

401 Error

Reply
0 Kudos
4 Replies
Highlighted
Esri Regular Contributor

Hi Ian,

Please capture a log of the behavior during the time of the publishing failure and upload it to this thread.  In addition, you can provide us with the XLSForm.

Troubleshoot—Survey123 for ArcGIS | ArcGIS 

Thanks,

Brandon

Reply
0 Kudos
Highlighted
New Contributor II

I thought the screenshot showed the log.... is that not the log you are speaking of? Or do you just want it expanded? Thanks

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Ian,

Please refer to the "Log errors to a console" section in the linked documentation.  You will want to follow the steps that describe how to save the log to a file and then you can upload it here.

Troubleshoot—Survey123 for ArcGIS | ArcGIS 

Also, please include the external CSV that you are referencing for your Pulldata calculations.  

Upon first look, it seems that you could benefit from utilizing 'external selects', considering that it appears you are using cascading selects and have over 8,000 choices in the choices sheet.

You can reference the documentation here for information related to external choices and how they can lead to enhanced performance 

Cascading and external selects—Survey123 for ArcGIS | ArcGIS 

Best,

Brandon

Reply
0 Kudos
Highlighted
New Contributor II

I am pretty familiar with the external choices tab. I'm not sure why I didn't use it initially on this survey. When I edited the .xls form, added the external choices tab, and moved my Location1 and Asset1 information, the form published. Thank you.

Reply
0 Kudos