Editing submissions in Survey123 Website appears different

673
9
Jump to solution
09-22-2021 08:32 AM
TristonRice
New Contributor III

This isn't a question as much as an observation, but since the last update I have noticed the item labels now display with all the syntax/appearance portion, whereas before the update they did not. One does still have the ability to edit a submission, however, it is now a bit more difficult to navigate. I republished the survey to 3.13 and the problem still persists. 

Is there any way to fix this, or is it simply something that needs to be brought to the developer's attention? 

0 Kudos
1 Solution

Accepted Solutions
JamesTedrick
Esri Esteemed Contributor

Hi @TristonRice ,

As part of the 3.13 release, the Survey123 website is now adopting the standardized acceptable HTML that can be used in ArcGIS Online. The <center> tag is not in the supported tag list (it was deprecated in HTML 4 in 1999). The alternative HTML is to use a <div style="text-align:center"> element.

View solution in original post

0 Kudos
9 Replies
AdminAccount2
Occasional Contributor

I've noticed the same thing - the html syntax is no longer respected. But, worse than that it appears in this latest version it no longer respects the value of the body::esri:visible field. It appears these fields are visible, but no longer editable.  I have values in there to hide some fields in the field survey, but they need to be visible and editable by approvers in the web form. They appear as visible, but not editable in this latest version of the web form.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi @TristonRice ,

As part of the 3.13 release, the Survey123 website is now adopting the standardized acceptable HTML that can be used in ArcGIS Online. The <center> tag is not in the supported tag list (it was deprecated in HTML 4 in 1999). The alternative HTML is to use a <div style="text-align:center"> element.

0 Kudos
TristonRice
New Contributor III

So is the correct response to go through every single question and change the label syntax? Are there any other tags that need to be altered as part of the adoption? Bold, indent, etc.?

0 Kudos
AdminAccount2
Occasional Contributor

I know <body bgcolor="#FBBCBC"><font color="black"><b>Mission Request</b></font></body> is another one that doesn't work any longer.

0 Kudos
TristonRice
New Contributor III

Also, traditionally we would end the string with either </center> or </>. Is this no longer necessary? I am by no means a computer scientist so laymen's terms are certainly appreciated. 

0 Kudos
AdminAccount2
Occasional Contributor

Thank you for the reply James. I can easily change the HTML, but that's not the major issue. I've opened up a support ticket for the other issue regarding the inability to edit a form in the web app (following the Sept 16 update) when there is a value in the body::esri:visible field. Any idea what change to the web app may have caused this? I've attached screenshots and examples to my support case here:   https://my.esri.com/#/support/cases/02897569

0 Kudos
AdminAccount2
Occasional Contributor

Also appears the form has issues loading the associated .csv file from the media folder when trying to edit:

Error appears after selecting editError appears after selecting edit

0 Kudos
AdminAccount2
Occasional Contributor

The .csv file is loading correctly now - user error on my part.

0 Kudos
JamesTedrick
Esri Esteemed Contributor

The appropriate closing tag is </div>

0 Kudos