Editing of hosted feature layer greyed out (still enabled in Settings) following change in choices.

858
6
02-12-2021 06:56 AM
KarlKeough3
New Contributor II

I created and published a survey, added several test records to it and created a web map in Portal. I was able to go into the webmap and edit in the usual way. I then updated the survey by adding a new choice for one of the fields and re-published. There were no error messages. Now, when I open the webmap and try to edit using the popup window, all the fields are greyed out and inaccessible. When i use the Edit button on the top left of the screen, it lets me add the point but all input boxes / dropdown menus are greyed out. Editing is enabled on the hosted feature layer (as seen in Settings).

Tags (2)
0 Kudos
6 Replies
by Anonymous User
Not applicable

Have you tried to enable the public editing on that layer? 

0 Kudos
KarlKeough3
New Contributor II

Thanks Monika. I'm not aware of any public editing setting. Do you mean sharing the layer publicly? I haven't done this as the data in question cannot be shared without going through a full data security assessment. At this time I am using this only as a demo. This data was able to be edited prior to my changing the "choices" in Survey123 form (xlsform document).

0 Kudos
by Anonymous User
Not applicable

MonikaWheat_0-1613154939386.png

This is the selection I was talking about. but if you have to do a full assessment I think that makes my answer not applicable 

0 Kudos
KarlKeough3
New Contributor II

Monika, that is great to know. I will likely use that setting when I do go live. Can you tell me where I find the setting? I don't see it in Survey123Connect, the Survey123 webpage or the feature layer page.

Thank you.

0 Kudos
by Anonymous User
Not applicable

It is in the settings on the feature layer in the top section

MonikaWheat_0-1613157288813.png

 

0 Kudos
KarlKeough3
New Contributor II

For some reason, I'm not getting that option Monika. Maybe that option is set at Administrator level?

KarlKeough3_1-1613162770499.png

 

 

0 Kudos