Edit data from hyperlink slow to open inbox

245
3
09-30-2020 12:22 AM
ChrisRoberts2
Occasional Contributor II

I have an existing feature service with about 5500 points.  These are refreshed in the Survey123 inbox, and called via a hyperlink in an Explorer Map. "arcgis-survey123://?itemID=187f8f4e007d427e83417bfee9e5bdff&action=edit&folder=inbox&update=true&filter=objectid:{objectid}"

When selecting the hyperlink the Survey123 opens immediately but it takes about 30-40 seconds for the feature to be displayed in the survey123 form.  Is there anyway that this performance can be improved.  That delay time just won't cut it for field staff

0 Kudos
3 Replies
Philip-Wilson
Esri Frequent Contributor

Hi Chris,

Are you using ArcGIS Online or Enterprise to host the existing feature service? 

Also what version of Survey123 field app and on what devices? Do you see the same timeframe on different OS?

Also, how big is the survey, does it have a lot of questions, choice lists, external csv files, and calculations?

When you open the same survey manually, via a new Collect or Inbox, how long does it take to open on same device?

Regards,

Phil.

ChrisRoberts2
Occasional Contributor II

Hi Phil

We are using Enterprise Portal 10.8.1

They are all using latest version of Survey123 (3.10x)

There does seem to be a slight variation, with the fastest being 10-12 seconds and the slowest up to 40 seconds.  The use case for is a  drive by survey so we could probably just live with a 10 second load time , but 40 seconds is just to long.  If we were doing a ramble survey then the delay wouldn't be such an issue.

The survey itself isn't overly huge, about a dozen questions, with 8 very short choice lists.  There are no external csv file or calculations.

If I search for and select the record directly from the inbox then it opens immediately.  Also creating a new record opens the form straight away.

Thats why I'm wondering if its the size of the inbox, I wouldn't of though that 5500 odd records is overly large?

Incidentally, if I launch the form from Collector as creating a new record, not editing an existing one, then it also opens pretty much immediately

Cheers

Chris

Philip-Wilson
Esri Frequent Contributor

Hi Chris,

Are you able to provide a copy of the xslx form so I can take a closer look and do some testing? I assume the URL in your first post is the exact URL you are using? If you do not want to attach the xlsx file to this post, let me know and I can send you my email address.

Having 5,500 records in the Inbox is still quite a lot, and not exactly what the Inbox was designed for. We have found generally up until 1,000 records it works well, and then depending on the complexity of the survey, number of fields or related tables, the speed may vary. Also depending on which OS and make/model device you are using has a difference in how fast the search works and expressions execute.

Are you able to limit the results downloaded to the Inbox on each device using a query, to only have the records that need to be edited, based on status or username?

Regards,

Phil.

0 Kudos