Displaying Survey 123 Multiple Choice Questions

272
2
01-16-2024 12:12 PM
Jaire_McNichols
New Contributor III

Good Afternoon!

My team and I are currently working with Survey123 and we're having some issues displaying the data for our multiple-choice questions. There are a handful of other posts on this forum detailing the same issue (the issue being that multiple-choice responses are returned as strings). The first example of this blog post is a perfect example of what we are trying to accomplish. This method 'worked', but the attached dashboard widget says that it cannot access the data, despite actively accessing the data and properly updating when we make additional test records. If this is working as intended, what can we do about the 'cannot access data' error message?

Jaire_McNichols_0-1705434358685.png

Assuming it isn't working as intended, what alternative means are there for treating these data strings to be usable? I also looked into the solution described here, but It seems to only apply to popups. An arcade expression that applies to the symbology of the layer might circumvent some of these issues, but any suggestions are appreciated!  Attached are example images

2 Replies
abureaux
MVP Regular Contributor

I'm not sure of the solution off-hand as I tend to do visuals in PowerBI, and I have to run soon so can't try to recreate this right now. But, I at least wanted to mentioned that since this seems to be an Experience Builder specific issue, you may wish to also post there (if you haven't already) as someone may have a more immediate answer for you.

0 Kudos
Jaire_McNichols
New Contributor III

Thanks for the reply! This is actually housed in a Dashboard app, but I went ahead and asked this question on the Dashboards forum as well. Thank you for the suggestion.

0 Kudos