Delete/Hide repeat_count fields on feature service

641
5
Jump to solution
05-24-2019 10:39 AM
deleted-user-EpRzjYvkmULR
New Contributor III

Is it possible to remove the repeat_count field that's created when publishing a survey containing a repeat_count?

I deleted these manually from my feature service on AGOL, but when republishing the survey from Survey123 Connect, it makes me add the fields again before I can publish. I would like to remove these to clean up my attribute tables on some of my more complicated surveys. I can set the bind::esri:fieldType to null for my note/calculate fields, but it doesn't seem to work for repeat groups.

I can't seem to find documentation on this anywhere, but I apologize if this has been covered elsewhere. Thanks!

0 Kudos
1 Solution

Accepted Solutions
JamesTedrick
Esri Esteemed Contributor

Hi Kade,

At this time the '_count' fields are necessary when using a calculation in the repeat_count field.  It can be worked around by placing the calculation in another field (with fieldType set to null) and setting repeat_count to that question without further calculation.

View solution in original post

5 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Kade,

At this time the '_count' fields are necessary when using a calculation in the repeat_count field.  It can be worked around by placing the calculation in another field (with fieldType set to null) and setting repeat_count to that question without further calculation.

View solution in original post

deleted-user-EpRzjYvkmULR
New Contributor III

Perfect. Thanks for the workaround!

0 Kudos
BamJam
by
New Contributor III

James Tedrick,

Can you please provide an xlsx example of the workaround that allows for limiting the repeat count without having to have the _count field in the feature service referenced in the submission url?  I would like to limit my repeat to 1, but am not able to avoid the _count field being required in the feature service.  Thanks! 

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Brandon, 

Unfortunately, a subsequent update has prevented this workaround from working.

0 Kudos
BamJam
by
New Contributor III

That explains the _count field being generated by S123 Connect regardless of what I enter in the repeat_count field.  In an attempt to publish my survey, I have created the necessary _count field in my feature service.  However, the field name is all uppercase in my Oracle db and thus the feature service.  This is preventing my survey from publishing due to the _count field that is automatically created by S123 Connect being all lowercase: 

 

Is there a way to control the case of the _count field that is created by S123 Connect?  Or, ignore case of the fields in the feature service when publishing?  Btw, I have tried to change the case of the field in my Oracle db, but it will not allow me to do so.

Thanks,
Brandon

0 Kudos