Custom report with many photos not working

135
7
02-01-2019 12:51 PM
Highlighted
New Contributor II

I'm using a custom report template in survey123 and the report works fine when I have less than 20 photos or so but I have a survey with over 60 photos and the status stalls at 0% and never finishes.  I've tried saving the file locally and on the server and it doesn't work either way.  I separated my custom report template into smaller groups of photos and was able to retrieve the whole survey. Will esri be increasing the allowable size of a report in the future?  Thank you

Tags (1)
Reply
0 Kudos
7 Replies
Highlighted
Esri Frequent Contributor

Hi Steven,

Do you get a specific error when the report fails or does it just hang? If there is an error can you provide the details otherwise can you provide the itemid of the survey and re-run the report so we can try to check the logs to see why it hangs.

It would appear it is a timeout issue, but we need to look into it further,

Phil.

Reply
0 Kudos
Highlighted
New Contributor II

Philip,

I'm not getting an error message the status just says "Creating...0%"  I just tried running the report again and had the same result.  The GlobalID is f7e48b6b-abd0-45f4-803f-e4fe2b097288.  Thanks again

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Thanks Steven, we will investigate further.

Zhifang Wang‌ Can you take a look at the log files for the survey above and see why report is failing?

Regards,

Phil.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Steven, 

Thanks for your feedback.

The id mentioned by Philip should be the Job ID of the report generation task, seems the one you provided is not a valid Job ID, can you please find it in the recent tasks panel as shown below? If the task hangs "Creating...0%" initially, it probably will end up in ~6 hours with error, you can find the Job ID then.

In addition, would you mind sharing some information about your photos? For example, in the report template which contains 60 photos, what is the average file size of each photo (like ~2MB)? Can you estimate how the total file size about all the 60 photos? If the total size could be e.g. hundreds of megabytes, it may lead to an error due to the max. memory size on our server-side machine.

Thanks,

Zhifang

Highlighted
New Contributor II

Sorry for the confusion.  The job ID is "Survey 1_17_2019_OID5_20190212104441" and each of the photos seem to be 2-3 MB.  I downloaded all of the photos separately and it's about 128 MB.  FYI, my Word report template resizes the photos so six can fit on one page.  I also have no constraints to the photo size in the Survey123 application.  Thanks again for the help

Highlighted
Esri Regular Contributor

Hi steven,

Thanks for the information which helps our investigation, it's most probably due to the memory issue. Will let you know when it's fixed.

By the way, sorry for the confusion in my previous description too, the job ID I meant should be shown as the following screenshot, the one provided is the filename of the report to be generated.

Reply
0 Kudos
Highlighted
New Contributor II

Job ID 15710e2bfe1543e8859e8a4dbbd8dfce.  Here's a screenshot

Reply
0 Kudos