Choosing how repeats show up in feature report

282
2
11-08-2023 01:42 PM
NativeStrategiesAdmin
New Contributor

I have two repeats in a feature report and I need everything in the first repeat to populate first and then the 2nd repeat to come in after. Here is a more in depth explanation. 

I have a survey connected to a field maps feature service that we use to collect points and photos. I want to use the feature service capability of survey123 to create our reports for said points. Below is a screenshot of my report template. 

NativeStrategiesAdmin_0-1699478698218.png

What I want to happen is for all the points in the Points_Repeat to populate in the report first and then the photos to show after. I have tried times with re arranging or changing things around but what I get is one point followed by its corresponding photo. That is shown below. 

NativeStrategiesAdmin_1-1699479588416.png

There are a total of 9 points in this report so what it would ideally look like is 9 consecutive points and then photos to be shown after. Any thoughts on this would be greatly appreciated. 

0 Kudos
2 Replies
abureaux
MVP Regular Contributor

Your Feature Report looks fine. You should have 9 copies of that table if you have 9 items in the repeat. Your example is what I would expect it to look like with 1 item in the repeat. Can you upload XLSX? Would help to see how the repeats are set up.

What is the point of getValue:"repeat"? If you are trying to display photos at their original quality, getValue:"" works.

0 Kudos
NativeStrategiesAdmin
New Contributor

The Get value commands was me just trying something out for another issue I was having. I have attached the XLSX form along with the full preview report. I am getting 9 tables and their corresponding photos but like I said I need all the tables first and then the photos to come in last. 

0 Kudos