Cannot read property 'username' of undefined

1097
4
05-18-2020 08:23 AM
AndrewMilanes
Occasional Contributor II

Using Portal 10.7.1, I'm trying to create a sample report template using the S123 website connected to my portal.  I get the following error when I select create sample template:

"An error occurred while saving the report template.  Cannot read property 'username' of undefined."

An older version of this survey contained a field for username, but I've since deleted it.  I deleted the form and feature service and republished, but I'm still getting this error.  I looked through all of the json and xml files and don't see reference to this field.  What am I missing?

0 Kudos
4 Replies
ZacharySutherby
Esri Regular Contributor

Hello Andrew, 

Is your ArcGIS Enterprise Portal configured with Integrated Windows Authentication? Additionally, is your Portal publicly available? Meaning if you were to try to hit your Portal from home without a VPN or from Starbucks, for example, can you successfully hit your Portal outside of your network? 

If either of those is true the error is expected, please use the ArcGIS Enterprise Support section of this article for reference: 

https://community.esri.com/groups/survey123/blog/2019/07/23/understanding-survey123-feature-reports 

Thank you,

Zach 

Thank you,
Zach
0 Kudos
AndrewMilanes
Occasional Contributor II

The Portal is not configured with integrated windows authentication.  The Portal is not publicly available.  A VPN is required for access.

So since my Portal is not public, Feature Reports are not available?

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello Andrew, 

That is correct because the Survey123 ArcGIS Online Feature report service needs to be able to reach your ArcGIS Enterprise Portal to process. 

Thank you,

Zach

Thank you,
Zach
0 Kudos
MicheleJett2
New Contributor

Hi Zach,

Does the Survey 123 ArcGIS Online Feature report service always have the same IP address?

Thanks,

Michele

0 Kudos