Can't upload Survey123 records

467
2
Jump to solution
09-21-2021 09:01 PM
MarcoPoetsch
Occasional Contributor II

Hi,

for one of my surveys my fieldworkers can't submit records anymore.
I investigated and I'm pretty confident that I was able to identified the cause. However, I do not know how to fix it.

In the Suvvey123 settings under CollaborateShare Survey > What can submitters do?

The tick boxes are all empty:

MarcoPoetsch3_0-1632282819259.png

 

When I enable the first record (Only add new records) and click on save, the page returns that the settings have been saved successfully. However, as soon as I refresh the page, nothing is ticked anymore.

If choose either Add and update records or Add, update and delete records, I get following error message:

MarcoPoetsch3_1-1632283175211.png

{"error":{"name":"ArcGISRequestError","message":"400: Unable to update feature service definition.","originalMessage":"Unable to update feature service definition.","code":400,"response":{"error":{"code":400,"message":"Unable to update feature service definition.","details":["Invalid definition for 'Capabilities'.","Invalid definition for System.String"]}}

0 Kudos
1 Solution

Accepted Solutions
alison_gou
Esri Contributor

Hi @MarcoPoetsch ,

Maybe you can try to directly set on feature server. In order to do this, please follow:

  1. go to your organization --content, find your survey under Folders. The folder name starts with 'Survey -'
  2. once your survey is found, click on folder name  and find feature server of which name ends with  '_fieldworker'.
  3.  go to setting -- What kind of editing is allowed? , click on 'add' 'delete' 'update' accordingly. Once this is set successfully, it should be reflected on Collaborate page of your survey.

Just give it a go and see if this would work.

Besides, I am also curious does this issue only happen to one survey or more than one surveys?

 

Regards,

Alison

View solution in original post

2 Replies
alison_gou
Esri Contributor

Hi @MarcoPoetsch ,

Maybe you can try to directly set on feature server. In order to do this, please follow:

  1. go to your organization --content, find your survey under Folders. The folder name starts with 'Survey -'
  2. once your survey is found, click on folder name  and find feature server of which name ends with  '_fieldworker'.
  3.  go to setting -- What kind of editing is allowed? , click on 'add' 'delete' 'update' accordingly. Once this is set successfully, it should be reflected on Collaborate page of your survey.

Just give it a go and see if this would work.

Besides, I am also curious does this issue only happen to one survey or more than one surveys?

 

Regards,

Alison

MarcoPoetsch
Occasional Contributor II

of course... I should have thought about that too.

It's working now... So all good. Thanks!

PS: this was the only one which made troubles 🙂

0 Kudos