Can I URL pass the Domain code instead of Description?

315
3
Jump to solution
03-28-2018 09:46 AM
DougBrowning
MVP Notable Contributor

I am passing fields from Collector to Survey123 using the URL format

arcgis-survey123://?itemID={SoilStabilityForm}&field:Office={Office}&field:PlotID={PlotID}&field:PlotKey={PlotKey}

The problem is that it is passing the Domain Description instead of the Domain Code for Office - which breaks all my constraints. 

Is there a way to pass the Domain Code instead of the Description? 

Thanks

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JamesTedrick
Esri Esteemed Contributor

Hi Doug,

Currently this isn't possible in Collector.  It should be possible in the new version of Collector under development (see https://community.esri.com/community/gis/applications/collector-for-arcgis/blog/2017/09/06/the-auror...), which will support Arcade expressions (see Data Functions | ArcGIS for Developers ).

View solution in original post

3 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Doug,

Currently this isn't possible in Collector.  It should be possible in the new version of Collector under development (see https://community.esri.com/community/gis/applications/collector-for-arcgis/blog/2017/09/06/the-auror...), which will support Arcade expressions (see Data Functions | ArcGIS for Developers ).

DougBrowning
MVP Notable Contributor

I was afraid of that.  Well my day just got longer.

Thanks for the response

BTW the kinda fix was to have my Domain codes and description the same.  At least I did not have to start all over...so far.

0 Kudos
JosephGrossman
New Contributor III

@JamesTedrick @DougBrowning Thank you both for writing about this. I was having the same issue. I was publishing data through a portal. When using the custom URL on the IPAD tablet I would get the domain description, while in the webmap the domain code was being pushed though. This was causing issues with dependent questions as well as not creating consistent data. It looks like using the Data Functions Data Functions | ArcGIS for Developers "DomainCode" function to make it set the "domain code" or "DomainName" to force it to be the "domain description". It was a little confusing, but I was able to get to work by using the format: DomainName($feature, 'fieldName')  and DomainCode($feature, 'fieldName').

0 Kudos