Basemap changes not seen in downloaded Survey123

255
12
05-07-2019 07:18 AM
Highlighted
MVP Frequent Contributor
We've impmented this to automate the updating of basemaps and republishing of a survey: https://community.esri.com/groups/survey123/blog/2017/12/08/an-alternative-way-to-update-the-media-f...
We're having an issue with the tpk basemaps added to the media folder and then republishing the Survey.  The entire workflow to build new tpk's, download the existing survey, build a new zip and upload to the form item all works correctly and we can see the form is updated just fine, however the basemaps do not update on the device(s).
Even after deleting and re-downloading the survey item, we don't see updates to the basemaps.  The only way we actually see the updates to the basemaps is when the Surve123 app is completely uninstalled and re-installed from the app store.  Only then after downloading the survey item again will the basemap changes appear.  It's very similar to a browser caching a previous session.
Is there something I'm missing or can look to do?
iOS v12.1.4
Reply
0 Kudos
12 Replies
Highlighted
Esri Esteemed Contributor

Hi James,

Can you either copy off the Survey123 folder from the device (see Troubleshoot—Survey123 for ArcGIS | ArcGIS ) or try to replicate this on your computer?  That way, you could confirm that the TPK file is not updating based on dates.

Highlighted
MVP Frequent Contributor

Thank you for the response James, I'll look into that.  Of note, using https://ago-assistant.esri.com/ I can see that the modified date of the form item is being updated when the scripting finishes.

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Yes, AGO Assistant would show the time- in particular I am concerned about the TPK's timestamp.

Highlighted
MVP Frequent Contributor

Hi James,

As an update: Everything is running fine, no errors, all expected changes in tpk are persisted into the uploaded Survey123 item (verified by downloading and adding the tpk into ArcGIS desktop).

The ONLY time the tpk updates are seen in the Survey123 is if I completely uninstall the app, re-install it from the app store and then download the specific Survey123 item again.  This then opens the survey's map with the correct/expected tpk changes.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi James,

What version of Survey123 are you using and on what device/OS version? does the same happen on Windows, Android and iOS?

Phil.

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

Hi Phillip!

It's the latest Survey123 version 3.5.177 just installed yesterday. Device details:

Device: iPad Air2

Software: 12.2

Model: MH2M2LL/A

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Is the size and details of the tpk the same, as the size of the tpk that was originally uploaded? The difference in file properties could be the cause of the problem?

Phil.

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

Hi Phil,

Yes, they both look the same to me.  

The left side image is from Connect's media folder after I re-downloaded since the Survey was updated this morning at 6:20am.  The right side image is from the zip file that was packaged up with the updated tpk and used to upload/update the Survey item on AGOL.

Also, this is the line in my script to build the tpk:

def buildTPK(mxd, outputTPK):
print '...building {} now'.format(outputTPK)
print 'mxd: {} | ONLINE | outputTPK: {} | PNG | 1 '.format(mxd, outputTPK)
arcpy.CreateMapTilePackage_management(in_map=mxd, service_type="ONLINE", output_file=outputTPK, format_type="PNG", level_of_detail="14", service_file="", summary="AVATAR Mobile HFS", tags="AVATAR", extent="")

Thanks again!

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

Hi Philip,

Is there anything else more I can look into to resolve this?  Also, is this something that can be looked into by ESRI support?

Thanks again!

Reply
0 Kudos