ArcGIS Online groups do not coincide with the groups shown in survey123

335
3
Jump to solution
01-29-2021 09:43 AM
Jelle_Stuurman
Occasional Contributor

Hi,

When I want to edit my collaboration settings for an survery123 using ArcGIS Online, the list of groups shown in the 'share survey' and 'share results' tab do not coincide with my groups shown in my ArcGIS Online 'groups' page. I came across this issue when creating both a web survey123 and a XLSForm survey123.

If I change the share settings of the form and feature service regarding the survey123 in ArcGIS Online itself, I ca no longer update the survey anymore using Survey123 Connector. I believe that is because my survey123 account does not see the right groups in which the content is shared in.

I am administrator and therefore can see all the groups present within the organisation. That shouldn't be the issue. 

I am using the latest 3.11.124 Survey123 connector app for Windows.

Anyone have any idea what is going wrong?

best,
Jelle

group settings arcgis survey123.png

0 Kudos
1 Solution

Accepted Solutions
Jelle_Stuurman
Occasional Contributor

I think there was an issue with the group. I was not even able to add members to the group in ArcGIS Online. 

After deleting the group and recreating it, things worked as expected both in ArcGIS Online and Survey123. 

View solution in original post

3 Replies
IsmaelChivite
Esri Notable Contributor

Hi. I am guessing this is a permissions issue.

  • ArcGIS Online will show all groups you have access to: To just see content or to also share content to. 
  • The collaborate tab in the Survey123 website will show only the groups on which you can share content. 

If your user has permissions to share into a group, it should display in the Survey123 website.

Survey123 Connect does not really interfere with Groups at all. However, for Connect to make edits on a survey, you must be the owner the Form item and the feature layer (unless you use submission_url).

The safest way to transfer ownership of a survey is through the Survey123 website.

0 Kudos
Jelle_Stuurman
Occasional Contributor

Hi Ismael,

Thank you for getting back.

Your comments make sense. Except that the group which I don't see in Survey123, is a group that I am owner of. Also it is set that all group members can contribute. I am admin and have maximum user type rights in ArcGIS Online. I am also owner and author of the survey.

Am I missing something?

0 Kudos
Jelle_Stuurman
Occasional Contributor

I think there was an issue with the group. I was not even able to add members to the group in ArcGIS Online. 

After deleting the group and recreating it, things worked as expected both in ArcGIS Online and Survey123.