Annotate image with GPS data (EXIF)

243
6
05-18-2018 11:03 AM
Highlighted
New Contributor III

When I try to use a photo (taked with Survey123 or another app - like OpenCamera, f.e.) with annotations (setting "annotate" in "appearance" column - field type "image"), the EXIF data is lost. I believe that it's a bug in Survey123 because when I trying to take a photo in this field using Survey123, the GPS widget symbol appears in the upper-right corner of the device screen, however the EXIF data is removed by the annotation session before return the photo to the form.

Please let me know if I'm doing something wrong or when this problem will be solved.

Thanks.

Reply
0 Kudos
6 Replies
Highlighted
Esri Esteemed Contributor

Hi Adilson,

This is an known limitation with the annotate question at this time.

Highlighted
New Contributor II

Has this issue been addressed?  Adding exif data with an annotated image, and if not, when will this enhancement be added.

Reply
0 Kudos
Highlighted
Frequent Contributor II

Would watermark work for you?  That is what I tried to add GPS to the image.  It does burn it in though, so if it is wrong it is there for good.

Reply
0 Kudos
Highlighted
New Contributor II

Watermarking is an interesting concept but I do need the annotate function.  It seems you cannot annotate and use watermarking together.  That would be ideal.  Thank you for your feedback.  I appreciate it.

Reply
0 Kudos
Highlighted
Frequent Contributor II

I do not use annotate but maybe you could store the values in text then add them via script later?

Reply
0 Kudos
Highlighted
New Contributor II

My work around has been to add a required geopoint question after the image capture, as the exif data will not capture from an annotated image.  Just wanted to avoid another question. 

Reply
0 Kudos