Adding Images/Attachments to Survey in INBOX

7289
49
Jump to solution
03-08-2018 11:30 AM
CoryLyle
New Contributor

Anyone have experience with adding photos to an existing survey through the Inbox? Or potential workaround?  We have office technicians that will be adding points to our feature layer (in portal), the field crew/inspectors will then navigate to these points, open the survey through the Inbox, and complete the survey including taking photos of the location.  

We would like the photos to be accessible through the web map in portal, which is why we chose to use multiple image questions instead of using repeats.  I read that you could possibly edit the source code for Survey123 through AppStudio, unfortunately I am not that familiar with coding and couldn't find any documentation.

I would greatly appreciate any recommendations!

Already read through the 2.4 "talk like a pirate release" blog post and saw this...but wanted to see if the community had anything new.

"As of this release, the Inbox lacks support for downloading attachments. That is, you can use the Inbox against a survey that includes attachments, but  the Inbox will not populate  signatures, annotated images, audio or image questions.  All these types of questions will appear empty, as if they had no data. As for the rest of questions, you will be able to download  data for them and update  them as well.

 

Also, to play on the safe side, when you edit surveys from your Inbox we will disable editing on these types of questions. This means that if you open a survey from your Inbox  to make edits to it, all questions of type image (photos, signature, annotate, draw) as well as audio questions will appear not only empty, but also disabled. This is to avoid people from accidentally attempting to change data  in them."

1 Solution

Accepted Solutions
Philip-Wilson
Esri Frequent Contributor

Hi @AdamBakiera,

The enhancement to support editing attachments and adding additional attachments while edit existing surveys is high on our priority list, one of the most requested. We are already doing initial work on this feature, and are aiming to have this feature available by the end of 2021. Keep an eye out in the Early Adopter Community for when updates are made the feature is available for beta testing.

Regards,

Phil.

View solution in original post

49 Replies
Philip-Wilson
Esri Frequent Contributor

Hi Cory,

As mentioned, we do not currently support editing of attachments via the Inbox. The attachments can not be downloaded via Inbox, and therefore can not be edited. Also attachments can not be added to an existing parent record in a survey, but can be added to new records in repeats.

The best workaround at present is to use a repeat for your image questions. If image questions are in a repeat, even though you are edited an existing feature (parent record), you are adding a new record to repeat, which allows adding a new photo. Note that this may mean you are unable to view the photos in a popup in webmap, as only images in the feature layer parent record will be shown there.

Phil.

HeatherFollis
New Contributor III

Hi Philip,

We are having the same issue, where I have based a survey off of an existing feature class. The field technicians would like to now go out and select that existing point/survey from the inbox and add an image and then be able to see the image in AGOL. You have mentioned to use a repeat to enable the image questions but then the photos will not be viewable in a popup in AGOL. Is there a workaround to get the images to show in AGOL?

Also, is this issue going to be addressed in future releases of either Survey123 or AGOL?

Sincerely,

Heather

0 Kudos
CoryLyle
New Contributor

Heather...depending on the length and setup of your survey, Collector may be an option. We use Collector for various other projects and it is great for editing existing features and adding attachments.

In my situation, our survey has too many conditional questions and is pretty lengthy, so Collector would be really cumbersome for the field inspectors to navigate through.

0 Kudos
HeatherFollis
New Contributor III

There are many conditional questions that would be annoying for the field workers trying to figure out which fields need to be edited for which feature, etc... So I have added this dilemma to the ideas page in hopes they can address it with great solution.

https://community.esri.com/ideas/14673 

Philip-Wilson
Esri Frequent Contributor

Hi Heather,

We do not have a current timeline for supporting editing of attachments (images) via the Inbox, as previously pointed out in other GeoNet posts and updates regarding this issue.

As for a workaround to display related table images in a pop up on a web map, I do not believe this is possible due to the one to many relationship and I do not know of any workarounds, however this is more of a ArcGIS Online webmap question, so you may be better off asking the question in that forum.

Phil.

0 Kudos
DanaThompson1
New Contributor III

Hello Philip,

Do you know if the status of this issue (now or in the near future) is still the same?

Thanks,

Dana

by Anonymous User
Not applicable

Hi Philip Wilson

I understand why images aren't supported in 'inbox.'

But, is there a way to display the image URLs in it instead?

Thanks,

Gee

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Geethaka,

Currently there isn't a way to display the URLs of the images - Survey123 does not make any requests regarding the attachments for the Inbox (to discover the URLs it would need to query the feature's attachments).

0 Kudos
by Anonymous User
Not applicable

Hello,

I have a quick question that is on this same subject/topic of working with existing features service that has a repeat and photos. However, I would like to allow users to add in multiple photos, but the nested repeats are not currently supported to add a repeat question for photos within the repeat.

So, I thought I could add a couple photo questions inside the repeat; well ok I added like 20 photo questions. I thought this form is going to be very long, but the crews would be able to revisit a site and add in new photos with each new record being added.

On my initial tests, I can add in new records within the repeat, but the images that I am loading up are "not" being uploaded to the feature service?

My initial attempt to add a new repeat allowed for the first three images to uploaded, but none of the additional new repeats have images associated to them?

Running iPad iOS 11.3.1 with Survey 123 v2.8.2 and I am using the established GlobalID relationships between the tables while I enabled the attachments to the related table and I have this within the repeat ESRI parameters "query allowAdds=true allowUpdates=true"

Please help as my crews are heading out at the end of the week. I would appreciate any feedback.

Thanks! Mike

0 Kudos