Adding a new field to an already published survey

765
4
Jump to solution
03-23-2021 01:27 AM
KerrieMcCarroll
New Contributor

I want to add a new question to an already published survey. I'm getting the warning below. According to documentation on Publish a survey—ArcGIS Survey123 | Documentation adding a new question without deleting the existing data in the feature service is allowed,  but I am looking for confirmation as I need to be 100% confident. There are thousands of records with attachments in the feature service, plus and an associated Operations Dashboard, so I don't want to have to re-create the survey. I'm using version 3.10.239. If I add the field when publishing the survey will it delete all of the existing data?

warning.JPG

 

1 Solution

Accepted Solutions
SMauri
by
Occasional Contributor III

Just add yourself this new field in Feature Hosted Layer data structure in ArcGIS Online UI: Add or delete a field—ArcGIS Online Help | Documentation

It's the same thing...

Cheers

Stefano

View solution in original post

4 Replies
SMauri
by
Occasional Contributor III

Just add yourself this new field in Feature Hosted Layer data structure in ArcGIS Online UI: Add or delete a field—ArcGIS Online Help | Documentation

It's the same thing...

Cheers

Stefano

IsmaelChivite
Esri Notable Contributor

Alternatively, if you simply turn on the switch control I highlight in the screenshot below, Survey123 Connect will add the field for you. As @SMauri indicated, it is the same thing.  With this warning, Survey123 Connect is simply asking for your confirmation before adding a new field to your layer. Adding the field manually or through Connect, no data will be lost.

IsmaelChivite_0-1616520415376.png

 

LynneWarwick
New Contributor II

I am having a similar issue. I have tried publishing the survey using both methods, the field is being created however, it is getting stuck and not completing the publish ( see photo below). This survey is linked to a field map, would that have anything to do with it? survey123 error.PNG

0 Kudos
KerrieMcCarroll
New Contributor

I added the new field to the hosted feature layer on ArcGIS Online and then published the survey123, that worked for me.

SMauri: "Just add yourself this new field in Feature Hosted Layer data structure in ArcGIS Online UI: Add or delete a field—ArcGIS Online Help | Documentation"

0 Kudos