Access Attachments & attributes of an existing feature service in Survey123

362
1
06-04-2021 12:07 PM
Kara_Shindle
Occasional Contributor III

Looking for answer to question and guidance - have an existing feature service hosted on my own server that has multiple related tables and attachments for each based on various workflows and reports that need done in the field.

Attachments enabled on main feature service itself - and I want to add fields into the Attachments table for collecting data in a Survey123 form - I want a user to be able to upload a photo / PDF and also enter their name and company along with the data an attachment was added.  I have added these fields into the Attachments table, and Global IDs are being used.

Photo of what the XLSForm looks like:

XLSForm.png

 

Note: I have already created multiple surveys off of this service for the related tables based on this blog post

When I attempt to do this with the attachments table on the main feature service, it tells me it cannot find the attachments table.  

Is this possible or do I need to create another related table populated with the fields I want to collect and enable attachments on that related table instead?

Picture of error I receive

bridge survey.png

 

0 Kudos
1 Reply
JamesTedrick
Esri Esteemed Contributor

Hi @Kara_Shindle ,

The error indicates that you are trying to create a form based on the attachment table.  This should not be done; in general, the attachment table should never be directly published from the feature service.  The image/files will automatically be added as attachments when the form is linked to the attachment's parent layer.

0 Kudos