Video not displaying on Mobile Device

271
3
07-16-2019 01:15 PM
HannahStaples
New Contributor II

I set a video to play on my cover page, but it does not display on mobile devices, only on desktop. Is there a way for videos to play on mobile devices?

0 Kudos
3 Replies
OwenGeo
Esri Notable Contributor

Hi Hannah -- sorry you are having trouble with the video in your story. Videos should work on the cover on mobile devices.

Can you publish and share with everyone so we can take a look and help troubleshoot? You can DM me the link if you prefer.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
HannahStaples
New Contributor II

Hi Owen,

Here is the link: https://storymaps.arcgis.com/stories/2411297810774ff28d3b6af7c5f0ac7c

After testing it a bit more, it seems like the video will display on Android devices after waiting a while to load. Before it loads a still image of the video is displayed. However, on iPhones, only a gray background appears instead of the video.

Additionally, when scrolling through a map sidecar, the map updates quickly on Android devices and is displayed at a large enough size to be useful, but on iPhones, the map does not update quickly, so it is easy for the user to scroll through the entire sidecar slides without having the map update at all. The map area also displays much smaller on iPhones, and it would be more useful if it maintained the same height that it does on Android devices.

All in all, it seems to behave differently across the different platforms.

0 Kudos
OwenGeo
Esri Notable Contributor

Hi Hannah - sorry for the delay in getting back to you. I just opened your story up on my iPhone and the video is working as expected. Can you please check again? We did fix some issues with cover videos in our last release, so it looks like the issue you were seeing was addressed.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos