Select to view content in your preferred language

Problem with hyperlinks when in fullscreen mode

361
2
05-24-2022 11:26 AM
Maricadg
New Contributor II
Hello, I'm working on my first StoryMap, and I have a problem with the hyperlinks.

This is a complex problem, and I'll try to explain it at my best.... but in order to do so, I need to briefly explain the structure of the StoryMap.
In my first Sidecar module called "The Trail Network" I have one slide with a map of the entire area (the San Dieguito River Park). The map contains all of the trails that are later described in the following sections of the StoryMap: four big groups called Coastal Trails, Valley Trails, Foothills Trails and Mountain Trails. 
Each group of trails is presented with a Sidecar module. Each sidecar module consists of several slides, approximately one for each trail. Each slide contains a map as a media, that is always the same map but focused each time on a different trail. For each slide, I used a subheading as a title.. so that each trail corresponds to a different subheading. I copied and saved the links to these subheadings, and I used them (to reference the trails to their descriptions) in my maps and throughout the StoryMap text. 
You can see for example in the picture attached that once I click on a trail a pop-up window shows up containing a link to the trail description.. these links are all working: if I click on any of them, the StoryMap redirects to the right slide. 
HOWEVER, if the very first map (the one in "The Trail Network") is in Fullscreen mode, and I click on a trail link, nothing seems to happen: the StoryMap doesn't show me the right slide, and what I see on the screen doesn't change. Instead, if I do the same thing in the other maps [in other Sidecars] in fullscreen mode, the StoryMap redirects to the right slide [I think in this case the links work because each link is redirecting to different slides but within the same Sidecar, while the first map has links redirecting to slides in other Sidecars].
That wouldn't be a real problem if actually nothing happened, but I later realized that if "The Trail Network" map is in fullscreen mode, and I click on a trail link, and then I exit the fullscreen mode, and I keep scrolling the Storymap, for each Sidecar section the maps in the slides don't show up in the right order... text and media are not matching to each other. This happens for all of the 4 sections. But if I go back to the start of the StoryMap, and I scroll it once again, everything seems to be in order again. 

My apologies if this is confusing, but it's an unexpected problem, and it is not easy to explain. I don't understand why only that very first map gives me problems only when in fullscreen mode. 
I'm thinking that an easy fix could be to disable the fullscreen mode for that map, but I didn't find a way to do it.

Please, let me know your thoughts or insights on this matter, or if you know a way to disable the fullscreen mode that would be fine too.
 
Thanks everyone for your precious time!
0 Kudos
2 Replies
OwenGeo
Esri Notable Contributor

Hi @Maricadg -- Thanks for taking the time to report this issue. This is a very involved issue that you have encountered and I'm afraid I don't have any specific advice I can provide. Also, there is currently no way to disable full-screen mode for maps.

Since the issue likely has to do with a very specific arrangement of content in your story, I think the best way to move forward trying to address this is to contact Esri Support. They will be able to capture any information needed for us to try to address whatever issue might be causing this.

Owen Evans
Lead Product Engineer | StoryMaps
Maricadg
New Contributor II

Thanks!
I'll try to contact Esri Support!

0 Kudos