How to add wms layer to the ArcGIS new storymap

423
4
05-15-2020 03:55 AM
GRIDArendal
New Contributor II

Hello,

We have a number of external wms layer that we want to add to the new storymap. 

We have created an ArcGIS online map using wms layer.

But when we are trying to add map to the new storymap the map is not visible even it is not listed in the legend. 

I can easily add maps to the ArcGIS classic storymap platform but it seems new storymap platform does not accept the WMS layers.

Thanks!

Deb

Tags (2)
0 Kudos
4 Replies
OwenGeo
Esri Frequent Contributor

Hi Deb -- Can you try opening your web map in the new Map Viewer beta (from its item page, just select the dropdown next to open) and let us know what you see?

The map viewer beta uses the 4.x version of the ArcGIS JavaScript API (the underlying web mapping technology of ArcGIS) just like ArcGIS StoryMaps, while the regular map viewer uses the 3.x version (like classic story maps). There is not yet full support for every layer type in the new 4.x version.

If this is the case, you can add your map to a 3.x configurable app like the basic viewer or minimalist and then embed that app into your story.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
GRIDArendal
New Contributor II

Thank you for your reply.

 The layer is visible in beta map and this time I have saved the map with a new name.

Further, I tried to add a new map to the storymap  but again it's not showing anything

I have also tried to add the basic viewer map as embed /iframe but it throws an error

Pleases note that we are using WMS layers from GeoServer.

 

Thanks!

Deb

0 Kudos
OwenGeo
Esri Frequent Contributor

Hi Deb -- I ran a quick test and I was able to see other WMS services in story maps (for example, this WMS service), so it seems like there is an issue with your service. Does the geoserver you're using have a valid security certificate? If you are able to share the map publicly we can take a quick look. Otherwise, I'd recommend that you contact Esri Technical Support and they will be able to help troubleshoot this specific issue.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
zhiyuanyaogis
New Contributor II

Hi, Owen, 

I have similar problem when I tried to add a WMTS service to the new Map Viewer (which worked using Map Viewer Classic). I tried multiple links, but none of them worked. I applied Web service and Tile service in the new Map Viewer. Both of them does not support the WMTS link (Here’s the link for my Georeferencer map:
https://maps.georeferencer.com/georeferences/03ac16a0-acfc-48bc-9675-68f978accc14/2021-03-10T16:58:1...). 

zhiyuanyaogis_0-1626976704912.png

zhiyuanyaogis_1-1626976810620.png

 

Thank you! 

ZY

 

0 Kudos