Embeded iframe issue with CSS styles

459
5
Jump to solution
12-09-2021 08:57 AM
Lvivcenter
New Contributor III

Hi, 

There were some changes in CSS made that affected the appearance of the published storymap especially when embedded as an iframe. Consequently, one of the elements that became larger than 100% affected the overall page - (data-blockid="n-ys80vM" id="n-ys80vM", see attachment 01) 
See the example here: https://storymaps.arcgis.com/stories/b8945044bcac4fd895effb90b0284226 (horizontal scroll bellow).

Could you please change the overflow here (see attachment 02)? That should fix the problem.

We would appreciate your help as it affected most of the stories we have created. 

Thank you!

Taras

 

Tags (2)
0 Kudos
2 Solutions

Accepted Solutions
ApurvaShah
Esri Contributor

Hi @Lvivcenter For the white frame border at the bottom of the viewport, it is not reproducible consistently, and it may have to do with the image size. 
The issue of the horizontal scrollbar will be fixed in our Jan 2022 release. 
Please let us know if you have any other questions or concerns. 

 

Thanks, 
Apurva Shah
Product Engineer | ArcGIS StoryMaps

View solution in original post

0 Kudos
OwenGeo
Esri Notable Contributor

This issue was addressed in yesterday's update. Release notes—ArcGIS StoryMaps | Documentation

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

0 Kudos
5 Replies
OwenGeo
Esri Notable Contributor

Hi @Lvivcenter -- I'm sorry you're seeing some issues with some of your stories. Unfortunately, I'm not quite sure I understand the issue you are describing.

You mentioned that there was an issue you observed when a story is embedded -- can you provide a screenshot of that? Can you also provide some information about when you last observed this working as expected and when you first observed the issue?

Thanks!

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
Lvivcenter
New Contributor III

Hi @OwenGeo, I've recently noticed that the stories I publish appear with a horizontal scroll (as on the attached screenshot taken from this page). At the same time, the stories I publish as an embedded iframe seem to how a white frame border at the bottom of the viewport (as on the attached screenshot taken from another page). It basically appeared yesterday. Because we didn't have this issue before. As far as we were able to investigate it with colleagues, the problem is in the updates of the CSS styles of the storymap - one of the elements is larger than 100% width, which causes the abovementioned problem. On the screenshots from my previous message, we tried to spot the exact place where the issue is located. 

I hope this clarifies. 

0 Kudos
OwenGeo
Esri Notable Contributor

@Lvivcenter - Thanks for the screenshots. I think I understand the issue now. I don't see those scrollbars on my Mac, but we'll do some investigation on Windows machines to see what might be going on.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
ApurvaShah
Esri Contributor

Hi @Lvivcenter For the white frame border at the bottom of the viewport, it is not reproducible consistently, and it may have to do with the image size. 
The issue of the horizontal scrollbar will be fixed in our Jan 2022 release. 
Please let us know if you have any other questions or concerns. 

 

Thanks, 
Apurva Shah
Product Engineer | ArcGIS StoryMaps

0 Kudos
OwenGeo
Esri Notable Contributor

This issue was addressed in yesterday's update. Release notes—ArcGIS StoryMaps | Documentation

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos