Add Video only Upload Option

927
6
Jump to solution
02-24-2022 09:57 AM
Aurust
by
New Contributor

I'm trying to add a link to a youtube video to a Explorer Map Tour as the media for a card and a video as a Content Block. When I click to add, I only get an option to upload from my PC and no option to add a link. I've looked through the help documentation and it seems like I should be able to use a link to the youtube video as an option. Is there a setting my administrator might have change that restricted this or is there something I need to do? 

This is the window I get when trying to add a Video:

Story Map Video.png

0 Kudos
2 Solutions

Accepted Solutions
OwenGeo
Esri Notable Contributor

Based on your question, I'm assuming that you are using ArcGIS StoryMaps on an ArcGIS Enterprise portal. Please let me know if that's not the case. Otherwise...

Yes, there is an organization setting on Enterprise portals that can be used to disable the ability to add linked media in StoryMaps. Only administrators have access to view or update the settings on this page, which is accessible via an admin's profile menu. These settings affect all members of the portal organization.

Yesterday, we added a new help topic that lists and describes these administrative settings, which you can find here: Administer ArcGIS StoryMaps on ArcGIS Enterprise—ArcGIS StoryMaps | Documentation

 

Screen Shot 2022-02-24 at 1.31.48 PM.jpg

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

0 Kudos
TPB_COGGIS_Team
New Contributor III

Owen,  the 'add' button was not active yesterday after populating a link but now it seems operational....go figure-- maybe it was the formatting of the URL but I tried a few. I will let you know if that changes, thx

View solution in original post

0 Kudos
6 Replies
OwenGeo
Esri Notable Contributor

Based on your question, I'm assuming that you are using ArcGIS StoryMaps on an ArcGIS Enterprise portal. Please let me know if that's not the case. Otherwise...

Yes, there is an organization setting on Enterprise portals that can be used to disable the ability to add linked media in StoryMaps. Only administrators have access to view or update the settings on this page, which is accessible via an admin's profile menu. These settings affect all members of the portal organization.

Yesterday, we added a new help topic that lists and describes these administrative settings, which you can find here: Administer ArcGIS StoryMaps on ArcGIS Enterprise—ArcGIS StoryMaps | Documentation

 

Screen Shot 2022-02-24 at 1.31.48 PM.jpg

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
TPB_COGGIS_Team
New Contributor III

Hi Owen  🙂

I am using Story Maps on the ArcGIS Online page and have the same problem. There are no general settings under the organizational settings so I think I am looking in the wrong place or missing something since I cannot link to content (embed, video, image)-- I only have the upload option

0 Kudos
OwenGeo
Esri Notable Contributor

@TPB_COGGIS_Team - Can you share a screenshot of what you are seeing? Please include the entire browser window including address bar in the image.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
TPB_COGGIS_Team
New Contributor III

TPB_COGGIS_Team_0-1646748199193.pngThe setting page and the story map showing the option to use a link to video is disabled. thanks-

TPB_COGGIS_Team_1-1646748329702.png

 

 

0 Kudos
OwenGeo
Esri Notable Contributor

Hmm, I'm sorry but don't understand what you are referring to in the second screenshot. I see the Link option as active, not disabled.

What happens if you paste a link in the field on the right side of that panel?

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
TPB_COGGIS_Team
New Contributor III

Owen,  the 'add' button was not active yesterday after populating a link but now it seems operational....go figure-- maybe it was the formatting of the URL but I tried a few. I will let you know if that changes, thx

0 Kudos