Android Build Error with C++

2768
2
Jump to solution
07-13-2015 08:31 AM
CeyhunYilmaz
New Contributor III

Hi everyone,

I have tried running Android kit with c++. But i get an error as in the attachments. I tried with Qt 5.4.0, 5.4.1,5.4.2 and ArcGIS Runtime 10.2.5, 10.2.6 .

Thanks

0 Kudos
1 Solution

Accepted Solutions
LucasDanzinger
Esri Frequent Contributor

Hi Ceyhun-

The C++ API is only supported on Windows and Linux as of the 10.2.6 release. Here is the C++ System Requirements that lists the versions of Windows and Linux that are supported for C++ development - System requirements—ArcGIS Runtime SDK for Qt | ArcGIS for Developers

We are looking into supporting this in the future. However, at this point, Android, iOS, and Mac development must be done using our QML API.

Thanks,

Luke

View solution in original post

0 Kudos
2 Replies
LucasDanzinger
Esri Frequent Contributor

Hi Ceyhun-

The C++ API is only supported on Windows and Linux as of the 10.2.6 release. Here is the C++ System Requirements that lists the versions of Windows and Linux that are supported for C++ development - System requirements—ArcGIS Runtime SDK for Qt | ArcGIS for Developers

We are looking into supporting this in the future. However, at this point, Android, iOS, and Mac development must be done using our QML API.

Thanks,

Luke

View solution in original post

0 Kudos
CeyhunYilmaz
New Contributor III

Thank you, Lucas

0 Kudos