Does ArcGIS Runtime SDK for Qt support static linking in Linux?

455
1
Jump to solution
07-24-2017 05:22 PM
RainerFarsch1
New Contributor II

I'm starting an application migration from using v10.2.6. to using v100.1; and I will be upgrading to Qt v5.9.1. In v10.2.6, I used dynamic linking for ArcGIS Runtime SDK for Qt since that is what was supported. However, that makes application deployment harder (including all the libraries and plugins) and is more susceptible to security hacks via these dynamically linked libraries. So, does v100.1 support static linking? Sure would be nice if it did...

Thanks!

-Rainer

0 Kudos
1 Solution

Accepted Solutions
LucasDanzinger
Esri Frequent Contributor

Hi Rainer,

Version 100.x does not support static linking on Linux.

Thanks,

Luke

View solution in original post

1 Reply
LucasDanzinger
Esri Frequent Contributor

Hi Rainer,

Version 100.x does not support static linking on Linux.

Thanks,

Luke