Tutorial HelloWorldApp MapView does not Load

1884
3
02-25-2016 07:46 PM
RandyCox
New Contributor

Hi All,

Sorry, I'm new to the ESRI desktop WPF SDK.  I'm just trying to run the 1st tutorial.

When I run the application, the map does not load in the map view window (see below).

I have been trying other samples, and mapview still wont load.  I tried hitting the URI directly and that works:

World_Street_Map (MapServer)

Is there something simple that I'm missing or any suggestions for troubleshooting?

Thank you for your help.

Windows 7

Visual Studio 2015


Image.png

<Window x:Class="HelloWorldMap3.MainWindow"

xmlns=http://schemas.microsoft.com/winfx/2006/xaml/presentation

xmlns:x=http://schemas.microsoft.com/winfx/2006/xaml

xmlns:d=http://schemas.microsoft.com/expression/blend/2008

xmlns:esri=http://schemas.esri.com/arcgis/runtime/2013

xmlns:mc=http://schemas.openxmlformats.org/markup-compatibility/2006

xmlns:local="clr-namespace:HelloWorldMap3"

mc:Ignorable="d"

Title="MainWindow" Height="350" Width="525">

     <Grid>

          <esri:MapView>

               <esri:Map x:Name="MyMap">

               <esri:ArcGISTiledMapServiceLayer ID="BaseLayer"

                     ServiceUri="http://services.arcgisonline.com/arcgis/rest/services/World_Street_Map/MapServer"/>

               </esri:Map>

          </esri:MapView>

     </Grid>

</Window>

0 Kudos
3 Replies
RandyCox
New Contributor

I tried the application at home on my commercial internet provider and it works fine.  Must be my company firewall/router settings.  Feel free to flag this question as answered.

Thanks.

0 Kudos
RandyCox
New Contributor

Hi Again,

Sorry, I'm an ESRI beginner.

Do you know where I could find the procedure used by this tutorial app to connect to ArcGIS Online.  I'm going to have a talk with our network team and wanted to know what they need to do to provide my tutorial app with access to ArcGIS online?  Are there any specific ports that need to be opened?  6080 or 6443?

I can hit the site directly using the URI below in a browser.

Thanks again for any help!

"http://services.arcgisonline.com/arcgis/rest/services/World_Street_Map/MapServer"

0 Kudos
dotMorten_esri
Esri Frequent Contributor

It's using standard HTML port 80.

Without knowing your network setup, it is possible you have to configure your app to use the system proxy (if there is one). This can be done in the app manifest.

<defaultProxy> Element (Network Settings)