Tracking Location problem

329
7
02-26-2021 12:36 AM
Dvirusb
New Contributor II

Hi,

I am trying to track location using 

 

LocationDataSource.LocationChanged 

 

event with 

 

SystemLocationDataSource

 

But this is what I get when I trying it in real devices (android devices)

Dvirusb_0-1614328231865.pngDvirusb_1-1614328299897.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(as you can see there is a lot of 'glitchs')

 

Occur in:

Runtime 100.09

Runtime 100.10 


Any suggestions?

 

0 Kudos
7 Replies
dotMorten_esri
Esri Frequent Contributor

Are you seeing the same thing if you use the built-in Google Maps app? (you should be able to run them side-by-side by going into a split view).

 

Also are you surrounded by a lot of very tall buildings, or do you have a clear view of the sky?

0 Kudos
Dvirusb
New Contributor II

Hi ,

Solved 🙂 - other yet workaround

I check HorizontalAccuracy before drawing.

But it's still look weird to see the blue circle (my location) jumping and than goes back.

 

With Google Maps app it's not happen.

 

 

 

0 Kudos
dotMorten
New Contributor

Could you also check what is in the 'AdditionalSourceProperties' dictionary on the location object you're getting, and compare a good with a bad location? This might give us some additional hints about what is going on.

0 Kudos
Dvirusb
New Contributor II

Something like that 😉

Dvirusb_0-1615928238545.png

 

Hope it's help.

 

0 Kudos
dotMorten
New Contributor

Thanks but that doesn't list any values in AdditionalSourceProperties

0 Kudos
Dvirusb
New Contributor II

Hi,

I am sorry under namespace Esri.ArcGISRuntime.Location

in version 100.09

there isn't  AdditionalSourceProperties 

Dvirusb_1-1615929377327.png

 

It's been add at 100.10

Dvirusb_2-1615929417532.png

 

 

0 Kudos
dotMorten_esri
Esri Frequent Contributor

Correct. What do you see in that collection using Update 10 ?

0 Kudos