MessageLayer Exception

2653
4
Jump to solution
10-29-2014 01:48 PM
KeithMacIntyre
New Contributor III

I am unable to get the MessageLayer to work in 10.2.4.

The layer appears to be loaded correctly but when I process a message I receive: The Message could not be processed. MessageLayer must have been successfully loaded into a View (Map or Scene) before calling ProcessMessage.

0 Kudos
1 Solution

Accepted Solutions
AnttiKajanus1
Regular Contributor II

Oh yeah, and are you using Nuget or SDK reference? Specialized symbology is not available on Nuget installation.

View solution in original post

0 Kudos
4 Replies
KatherineDalton
Esri Regular Contributor

Hi Keith,

I've definitely seen this before. In our Message Processing sample, we use await MyMapView.LayersLoadedAsync(); before processing the message data. Have you tried that?

Katy

Katy Dalton | Technical Consultant
THE SCIENCE OF WHERE™
0 Kudos
AnttiKajanus1
Regular Contributor II

What is error message in inner exception. That usually says a bit more.

Check that MessageLayer finds symbology that you are using either from the deployment (create deployment and make sure you deploy symbol dictionary) or from the SDK installation. See that ArcGISRuntimeEnvironment.SymbolsPath Property targets the file.

0 Kudos
AnttiKajanus1
Regular Contributor II

Oh yeah, and are you using Nuget or SDK reference? Specialized symbology is not available on Nuget installation.

View solution in original post

0 Kudos
KeithMacIntyre
New Contributor III

I had installed the ToolKit using NuGet and it copied the 10.2.4 Runtime to my deployment folder so my application was using that folder without the Specialized Symbology rather than my installed SDK folder.  It is working now.

0 Kudos