Could not create rendering pipeline 're_texture_draw'. API message: Target OS is incompatible: library was not compiled for the simulator

281
0
02-18-2021 01:01 PM
HectorMeneses
New Contributor II

I'm getting the following error when running my Xamarin iOS App using ArcGISRuntime 100.9 in the simulator for iPhone 12 Pro iOS 14.4 ( it also happens in other simulators ).

Could not create rendering pipeline 're_texture_draw'. API message: Target OS is incompatible: library was not compiled for the simulator

 at Esri.ArcGISRuntime.ArcGISException.HandleCoreError (RuntimeCoreNet.GeneratedWrappers.CoreError error, System.Boolean throwException) [0x0000f] in <9e8a01b31405463487a37647bbb4f045>:0

  at RuntimeCoreNet.GeneratedWrappers.Interop.CheckError (System.IntPtr errorHandle, System.Boolean throwOnFailure, System.Runtime.InteropServices.GCHandle wrapperHandle) [0x0002e] in <9e8a01b31405463487a37647bbb4f045>:0

  at RuntimeCoreNet.GeneratedWrappers.CoreGeoView.Draw (RuntimeCoreNet.GeneratedWrappers.CoreDevice device) [0x0001f] in <9e8a01b31405463487a37647bbb4f045>:0

  at Esri.ArcGISRuntime.UI.Controls.GeoViewMetalRenderer.RequestRender (System.Boolean isResize) [0x0002d] in <feaa53e84d7043e88504283a2c404a62>:0

  at Esri.ArcGISRuntime.UI.Controls.GeoView.RequestRender (System.Boolean isResize) [0x00000] in <feaa53e84d7043e88504283a2c404a62>:0

  at Esri.ArcGISRuntime.UI.Controls.GeoView.RuntimeCoreNet.GeneratedWrappers.ICoreCallback_GeoView_DrawRequested.DrawRequested () [0x00037] in <feaa53e84d7043e88504283a2c404a62>:0

  at RuntimeCoreNet.GeneratedWrappers.CoreGeoView.onPrivateCoreGeoView_DrawRequested (System.IntPtr externalUserData) [0x00030] in <9e8a01b31405463487a37647bbb4f045>:0

  at (wrapper native-to-managed) RuntimeCoreNet.GeneratedWrappers.CoreGeoView.onPrivateCoreGeoView_DrawRequested(intptr)

  at (wrapper managed-to-native) RuntimeCoreNet.GeneratedWrappers.CoreGeoView.CoreRT_GeoView_pulse(intptr,intptr&)

  at RuntimeCoreNet.GeneratedWrappers.CoreGeoView.Pulse () [0x00006] in <9e8a01b31405463487a37647bbb4f045>:0

  at Esri.ArcGISRuntime.UI.Controls.GeoViewMetalRenderer.MetalKit.IMTKViewDelegate.Draw (MetalKit.MTKView view) [0x00006] in <feaa53e84d7043e88504283a2c404a62>:0

  at (wrapper managed-to-native) UIKit.UIApplication.UIApplicationMain(int,string[],intptr,intptr)

  at UIKit.UIApplication.Main (System.String[] args, System.IntPtr principal, System.IntPtr delegate) [0x00005] in /Users/builder/azdo/_work/1/s/xamarin-macios/src/UIKit/UIApplication.cs:86

  at UIKit.UIApplication.Main (System.String[] args, System.String principalClassName, System.String delegateClassName) [0x0000e] in /Users/builder/azdo/_work/1/s/xamarin-macios/src/UIKit/UIApplication.cs:65

 

 

Has anyone seen this error? We are trying to upgrade from 100.5 to 100.10 (100.10 has the same issue).

 

 

 

0 Kudos
0 Replies