Xamarin.Forms Android map won't load

846
1
Jump to solution
02-08-2018 03:00 PM
PaulTallett
New Contributor II

Hi!

I have ArcGIS working on iOS and Windows UWP, but my shared page won't load on Android. I get the following error at runtime (it all builds okay):

02-08 22:37:39.244 D/Mono (23711): DllImport searching in: 'libRuntimeCoreNet' ('libRuntimeCoreNet.so').
02-08 22:37:39.244 D/Mono (23711): Searching for 'CoreRT_MapView_create'.
02-08 22:37:39.244 D/Mono (23711): Probing 'CoreRT_MapView_create'.
02-08 22:37:39.244 D/Mono (23711): Found as 'CoreRT_MapView_create'.
02-08 22:37:39.244 W/dalvikvm(23711): Unable to resolve superclass of LEsri/ArcGISRuntime/UI/MapView; (3279)
02-08 22:37:39.244 W/dalvikvm(23711): Link of class 'LEsri/ArcGISRuntime/UI/MapView;' failed
02-08 22:37:39.254 W/dalvikvm(23711): Unable to resolve superclass of LEsri/ArcGISRuntime/UI/MapView; (3279)
02-08 22:37:39.254 W/dalvikvm(23711): Link of class 'LEsri/ArcGISRuntime/UI/MapView;' failed

I have added NuGet's for Esri.ArcGISRuntime and Esri.ArcGISRuntime.Xamarin.Forms to my Android project.

Any help appreciated!

Cheers,

Paul

0 Kudos
1 Solution

Accepted Solutions
PaulTallett
New Contributor II

Didn't expect it to take 10 days to get posted. Figured it out in the meantime, turns out there are two ESRI.ArcGISRuntime DLLs ESRI.ArcGISRuntime and ESRI.ArcGISRuntime.Android (which shows up as ESRI.ArcGISRuntime when you add it). Very confusing. Of course I had the wrong one.

View solution in original post

0 Kudos
1 Reply
PaulTallett
New Contributor II

Didn't expect it to take 10 days to get posted. Figured it out in the meantime, turns out there are two ESRI.ArcGISRuntime DLLs ESRI.ArcGISRuntime and ESRI.ArcGISRuntime.Android (which shows up as ESRI.ArcGISRuntime when you add it). Very confusing. Of course I had the wrong one.

0 Kudos