WPF map freezing when using remote desktop

944
5
12-15-2017 07:17 AM
DavidMillican
New Contributor II

I found this post that describes what sounds like exactly what I'm experiencing but the thread never confirmed a fix. The representative thought that 10.2.7 might have fixed it but I am seeing it in my application and I am running 10.2.7. If there is a code solution I'd love to hear about it. 

Thanks,

David

0 Kudos
5 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi,

We addressed several issues with remote desktop sessions and virtualized environments for the v100.1 release (improved software rendering fallback and better detection under specific conditions).

I recommend moving to the newer v100.x SDK at earliest opportunity in your development cycle. There's a migration topic in the Guide (Migrate from 10.2.x to 100.x—ArcGIS Runtime SDK for .NET (WPF) | ArcGIS for Developers). There were a couple of functional gaps between v10.2.x and v100.x but those are rapidly closing with the 100.1 release and more so with the upcoming v100.2 release.  

Cheers

Mike 

0 Kudos
DavidMillican
New Contributor II

Hello Michael. I understand that everyone should move on to the still very new v100. I started a project not long ago here and actually decided against moving to v100 because it was still too new and was still missing some features that we had in use here today. It just represented too costly of a change for us to undertake at the time and we are still in that boat for now. The thread that I referenced claims that some conversation was had with Microsoft and that there was at least a proposed fix. Any information that could be shared on this would be helpful. Perhaps there is something that we could do in our code to help prevent this without any change to the ArcGIS SDK. I'm sure we will be moving on to v100 in the near future but we have to find a fix for this for now.

0 Kudos
DavidMillican
New Contributor II

Hmmm... looks like this may be a problem with v100 as well.

Release notes for 100.1—ArcGIS Runtime SDK for .NET (WPF) | ArcGIS for Developers 

0 Kudos
dotMorten_esri
Esri Frequent Contributor

Are you using multiple map views? Does the problem go away when you don't?

The fix that was referred to was to work around an issue Microsoft's RDP protocol. Basically if you try and render the map at 60 frames per second, the RDP session could hang the app. We are now detecting RDP and drop the framerate to 30fps, which resolves the issue and was also the recommendation we got back from Microsoft.

0 Kudos
DavidMillican
New Contributor II

So we are currently encountering this problem with only one map view in use. The problem occurs as soon as we load the form that contains the map view. I'm not sure if it is OS specific yet but we are certainly seeing this regularly on one of few Win 7 machines that we still have in use. So is this frame rate drop under RDP currently in the 10.2.7 code? If so then I'm having a different problem. 

0 Kudos