When I use Locator to search for intersections, why do I get less search results at ArcGIS Runtime than ArcGIS Pro?

945
7
Jump to solution
09-05-2018 07:48 AM
YongYao
New Contributor

I package a mmpk including locator.

When I use ArcGIS Pro - Locate panel to search street intersection, I expect to get the same result in the program written based on ArcGISRuntime.WPF 100.1.0.

I found all of the intersections in ArcGIS Pro. However just a little above half of the intersections can be found in the program.

Any suggestions for how to find the issue?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
MaraStoica4
Occasional Contributor

I am looking into this trying to replicate it and I am finding some discrepancies myself between the Pro and Runtime results. Pro seems to require less information to return all the results. In my test locator, if I use just the address, Pro finds 4 results, while Runtime doesn't find any. Once I add the city, Runtime also finds 4 results. Could you maybe try to adjust your search string to include more information? Does that change the results you receive? In the meantime I'll keep researching this, see what I can find out. 

View solution in original post

7 Replies
MaraStoica4
Occasional Contributor

Hi Sara,

Could you post the code where you're calling the locator please. 

Mara

0 Kudos
YongYao
New Contributor

var geocodeParams = new GeocodeParameters();
geocodeParams.OutputSpatialReference = SpatialReferences.Wgs84;

IReadOnlyList<GeocodeResult> addresses = await locator.GeocodeAsync(userTypedAddress, geocodeParams);

foreach (GeocodeResult match in addresses)
{

...

}

0 Kudos
MaraStoica4
Occasional Contributor

I am looking into this trying to replicate it and I am finding some discrepancies myself between the Pro and Runtime results. Pro seems to require less information to return all the results. In my test locator, if I use just the address, Pro finds 4 results, while Runtime doesn't find any. Once I add the city, Runtime also finds 4 results. Could you maybe try to adjust your search string to include more information? Does that change the results you receive? In the meantime I'll keep researching this, see what I can find out. 

YongYao
New Contributor

Hi Mara, thank you for your reply. It really helps. And I am able to explain this weird issue to customers.

In my case, even I add the city name, it doesn't change the result.
If you find out any other tricks can help locator get more result in Runtime, please let me know. Thanks.

 

0 Kudos
MaraStoica4
Occasional Contributor

Would you be able to share your data with me so I can see exactly the issue you're running into? mstoica@esri.com

0 Kudos
DritanZhuja
New Contributor

Hello Mara,

Based on this discussion, has there been any work to match the ArcGIS Runtime locator requirements to that of ArcGIS Pro? If so, could you please provide the BUG or ENH number where this work is being tracked.

0 Kudos
MaraStoica4
Occasional Contributor

I believe a workaround was found for this issue by disabling measures on ROADCENTERLINE feature class and rebuilding the locator. 

0 Kudos