UniqueValueRenderer RotationExpression doesn't work in Scene?

2941
5
Jump to solution
11-26-2015 06:14 AM
RobertKennedy
New Contributor

Hello,

I'm using the RotationExpression on a UniqueValueRenderer to rotate some PictureMarkerSymbols, this works like a charm in a Map but seems to have no effect in a Scene.

Can anyone confirm?  If so, any suggested workarounds?

(Simplest way to test is to just modify the UniqueValueRendererSample, add in the bits to introduce a RotationExpression, see that it works then change it to a Scene in the xaml and note that it doesn't any more).

Thanks

0 Kudos
1 Solution

Accepted Solutions
AnttiKajanus1
Regular Contributor II

Hi,

It seems that if you are using GraphicsOverlays or GraphicsLayers in Dynamic rendering mode (which is the default), RotationExpression is not working in SceneView. If you set the overlay/layer to use RenderingMode = Static, it should work. Symbol might look a bit smaller in that mode, but as a workaround you can use a bit larger symbol.

I have created issue for this.

View solution in original post

0 Kudos
5 Replies
AnttiKajanus1
Regular Contributor II

Hi,

It seems that if you are using GraphicsOverlays or GraphicsLayers in Dynamic rendering mode (which is the default), RotationExpression is not working in SceneView. If you set the overlay/layer to use RenderingMode = Static, it should work. Symbol might look a bit smaller in that mode, but as a workaround you can use a bit larger symbol.

I have created issue for this.

0 Kudos
RobertKennedy
New Contributor

Thanks Antti, it looks like you're spot on.  Unfortunately the change to static won't work for us as these items are changing position frequently and are at altitude.  We'll take a look at using individual PictureMarkerSymbols until there's a release with a fix.  Thanks again.

0 Kudos
AnttiKajanus1
Regular Contributor II

Just for extra information, this issue also seems to come if you are using SimpleRenderers so it's not purely related to UniqueValueRenderer. One work around as Robert said, is to use individual symbols (with angle property) and avoid using a renderer. Unfortunately this is as performant solution but hopefully solves the issue until we have a fix.

0 Kudos
RobertKennedy
New Contributor

Found a related issue with this - it looks like if you change the a PictureMarkerSymbol's Angle after initial creation it has no effect in a Scene unless you also change something is like its Width or Height as well. How to reproduce:

  1. Add a Graphic with a PictureMarkerSymbol
  2. Wait a bit and set that symbol's Angle, note that it has no effect
  3. If you change both its Angle and its Width is does the redraw as expected

(Note that changing just the Angle works fine in a Map)

0 Kudos
AnttiKajanus1
Regular Contributor II

That seems to be the case. I have created issue for that. Issue seems also occur with SimpleMarkerSymbols.

0 Kudos