System.NotSupportedException: Could not activate JNI Handle 0x7fca1a7480 (key_handle 0x2ad6405) of Java type 'Esri/ArcGISRuntime/UI/MapView' as managed type 'Esri.ArcGISRuntime.UI.MapView'.

4156
10
11-29-2016 01:19 AM
NadirHussain
Occasional Contributor II

my mobile is in debug mode.how to solve this on mobile device.


System.NotSupportedException: Could not activate JNI Handle 0x7fca1a7480 (key_handle 0x2ad6405) of Java type 'Esri/ArcGISRuntime/UI/MapView' as managed type 'Esri.ArcGISRuntime.UI.MapView'.

how 

0 Kudos
10 Replies
PreetiMaske
Esri Contributor

Can you please check that project properties > Android Options> Advanced Tab has the architecture that matches the architecture of the mobile to be checked ON. See image above for reference.

Let me know.

0 Kudos
NadirHussain
Occasional Contributor II

dear preeti maske

where is image,my mobile device is samsung galaxy s7 edge.in supported architecture all options are selected.

0 Kudos
PreetiMaske
Esri Contributor

Hope you see the image now. This is the image I was referring too. But I guess you got what I was asking to check.

Ok so, does the app work/deploy in release mode? As an FYI, there are some issues with arm64-v8a architecture that are currently under investigation. Would it possible for you to uncheck arm64-v8 and test running/deploying your app?

-Preeti

0 Kudos
NadirHussain
Occasional Contributor II

Dear Preeti

i could not send the output on device if i uncheck any of above options.In release mode my app release and install successfully.But when i open the app and tap on map to zoom or identify my app .it throws the exception "unfortuneatly app stopped" and crashed.please help it have already taken take lot of times.

Thanks

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

To summarize the discussion so far:

- In debug mode you see: System.NotSupportedException: Could not activate JNI Handle 0x7fca1a7480 (key_handle 0x2ad6405) of Java type 'Esri/ArcGISRuntime/UI/MapView' as managed type 'Esri.ArcGISRuntime.UI.MapView'.

- In Release mode you see: "Unfortunately, <your app name> has stopped." 

Please can you confirm for both Debug and Release modes what options you have enabled on the Packaging and Advanced tabs under Project Properties > Android Options? (i.e. 4 images similar to the image my colleague Preei posted above).

Note when your Android app is set to build/deploy as Debug, by default all CPU architectures are enabled but note these will be ignored because the `Use Shared Runtime` and `Fast Deployment` options are enabled (in Project Properties > Android Options > Packaging tab). When your app is set to build/deploy as Release, on the Android Options > Advanced tab, by default just armeabi-v7a is enabled. For more information please see the Xamarin doc on this subject: CPU Architectures - Xamarin.

Currently we do not support arm64-v8a as a target architecture in debug or release, but apps built for armeabi-v7a will work on both 32-bit and 64-bit ARM devices.

Cheers

Mike

0 Kudos
NadirHussain
Occasional Contributor II

Dear Sir 

the above image is the settings for debug and for release mode is setting is in below image.what can be the reason i cant debug my application.Because if i make same settings for debug mode my application. i could not create package i cant install.if i make same settings like release mode in dubug process my application not load in emulater not come to visible mobile device.please help we have already lost lot of time. 

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

The debug and release settings for 'Supported architectures' look ok. If you create a new Android application from the ArcGIS template do you see the same problem? 

Cheers

Mike

0 Kudos
NadirHussain
Occasional Contributor II

Hi,

i am facing the same problem even on new application some time.

0 Kudos
SougataBasu
New Contributor

Hi, 

I am facing the same problem while working with ESRI map in a existing project.

Below is the package  information - 

package id="Esri.ArcGISRuntime.Xamarin.Android" version="100.2.0" targetFramework="monoandroid60"

This error exists in version="100.2.1" also.

I have followed the previous replies on this thread. But that doesn't work for me. 

Please reply with some solution ASAP.

0 Kudos