MMPK with Basemap

640
4
Jump to solution
07-20-2017 12:26 PM
MarkCederholm
Regular Contributor II

Here's an example of a mobile map package containing a map with a basemap layer.  If I use the map directly, or copy the operational plus basemap layers to a new map, it will not render and hangs up.  If I copy only the operational layers to a new map, the map will render.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JenniferNery
Esri Regular Contributor

Hi Mark,

Thanks for reporting this issue. I'm able to reproduce the issue with released versions of the API v100.x. While I am not sure what is causing the basemap layers to fail during load, the issue appears fixed in our current version. I can find out for you if there's a workaround for this. 

View solution in original post

0 Kudos
4 Replies
JenniferNery
Esri Regular Contributor

Hi Mark,

Thanks for reporting this issue. I'm able to reproduce the issue with released versions of the API v100.x. While I am not sure what is causing the basemap layers to fail during load, the issue appears fixed in our current version. I can find out for you if there's a workaround for this. 

0 Kudos
MarkCederholm
Regular Contributor II

If you can find a workaround, that's great, but it's not a huge issue for me.  Normally I only store operational layers in a mobile map package:  I was just playing around with base layers to see how they worked.

0 Kudos
JenniferNery
Esri Regular Contributor

Hi Mark,

According to the developer who worked on the fix, you can do the following for the meantime:

To avoid the problem user can:

  • Remove indexes for UUID fields
  • Use fields of string type instead of UUID, if it is possible.
0 Kudos
MarkCederholm
Regular Contributor II

Thanks for the info!

0 Kudos