gpkx failed to load in ArcGIS Runtime

815
8
09-27-2020 08:12 PM
zhengmeiyan
New Contributor
I want to create a  geoprocessing package to convert featureclasses and tables from file geodatabases into oracle geodatabase. This package is a custom tool  created in ArcGIS Pro, and it's script is python including xml file. This package was generated successfully. But when I using it to ArcGIS Runtime on Local Server, error occurs. The error message is as follows:
Esri.ArcGISRuntime.Http.ArcGISWebException:“Failed to create service importlandsd GPServer. Service failed to initialize: The Geoprocessing package is not supported by the ArcGIS Runtime. There is no _sd.tbx file in the package. Check that it was authored with ArcGIS Runtime support enabled.
0 Kudos
8 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi,

When packaging the result, did you specify the option to Support ArcGIS Runtime?

Prepare a geoprocessing service for offline use | ArcGIS for Developers (Step 14)

Thanks

Mike 

0 Kudos
zhengmeiyan
New Contributor

Hi Mike,

I cann't find the option "Support ArcGIS Runtime". I'd checked the options in both the Geoprocessing Package and the current project, still cannot find it. Can you show me where is it?

My ArcGIS Pro Version is 2.6. The following is the UI of generating gpk with no error.

Thank you

Yanzhengmei

 

 

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

Note you need to use the Package Result tool Prepare a geoprocessing service for offline use(Step 11).

Thanks

Mike

0 Kudos
zhengmeiyan
New Contributor

I'd followed the steps to share a gpkx. But cannot find the option 'Support ArcGIS Runtime', neither it's in the geoprocessing package pane, nor is in the project option pane. The problem is where to fine the option 'Support ArcGIS Runtime', can you show me?

 

 

0 Kudos
zhengmeiyan
New Contributor

I'd followed the steps to share a gpkx. But cannot find the option 'Support ArcGIS Runtime', neither it's in the geoprocessing package pane, nor is in the project option pane. The problem is where to fine the option 'Support ArcGIS Runtime', can you show me?

 

 

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

It is an option on the Package Result tool (Package Result (Data Management)—ArcGIS Pro | Documentation ).

Thanks

Mike

0 Kudos
zhengmeiyan
New Contributor

Hi,

You mean the option "Support ArcGIS Runtime" cannot not be specified in the geoprocessing package pane, only be specified in tool?

I'd tried to use this tool but failed. I'd run the ImportLandsD tool for many times, so there are more then one results with the same name. 

How to set the in_result value for PackageResult_management?

 

 

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

If you are using the GP Tool user interface you can specify the result from the drop down menu (see below) or alternatively use the result id string from you current project in Python.

Thanks

Mike

0 Kudos