Complex buffer polygons

2658
11
Jump to solution
08-12-2015 04:11 PM
MarkCederholm
Regular Contributor II

I have some complex buffer polygons displayed from a runtime geodatabase.  If I'm zoomed all the way out, they appear fine, but when I zoom in closer, errant lines shoot all over the place.  Is there a known limitation for rendering polygons?

0 Kudos
1 Solution

Accepted Solutions
AnttiKajanus1
Regular Contributor II

I have logged a bug issue for this, thanks for providing repro. Could you also provide repros for the GeometryEngine issues that you are seeing?

View solution in original post

11 Replies
AnttiKajanus1
Regular Contributor II

Hi Mark,

Not that I know. Could you create a simple producer for the issue?

0 Kudos
MarkCederholm
Regular Contributor II

I've attached an example.  When I just buffered AZ highways, the problem didn't appear.  Then I buffered AZ towns and appended the two classes together, and that did the trick (zoom into the southern part of the state).  There seems to be more of a problem with rendering lots of widely scattered little polygon parts.

0 Kudos
MarkCederholm
Regular Contributor II

FYI, I'm also seeing GeometryEngine errors on the two test polygons:

Internal error exception

   at RuntimeCoreNet.Interop.HandleException(Boolean retVal)

   at RuntimeCoreNet.CoreGeometryEngine.Intersects(ICoreGeometry coreGeometry1, ICoreGeometry coreGeometry2, CoreSpatialReference coreSpatialReference)

   at Esri.ArcGISRuntime.Geometry.GeometryEngine.Intersects(Geometry geometry1, Geometry geometry2)

Update:  If I simplify the polygons, the intersection test works.

Update 2: I just looked at the results of the simplify, and they're bogus.

0 Kudos
AnttiKajanus1
Regular Contributor II

I have logged a bug issue for this, thanks for providing repro. Could you also provide repros for the GeometryEngine issues that you are seeing?

MarkCederholm
Regular Contributor II

Attached

0 Kudos
AnttiKajanus1
Regular Contributor II

Thanks Mark again, I have confirmed issue and logged a bug issue for these ones.

0 Kudos
MarkCederholm
Regular Contributor II

FYI, as a workaround, I have accomplished production-level workflow using arcpy to slice the polygons into smaller chunks before exporting to Runtime content.

0 Kudos
AnttiKajanus1
Regular Contributor II

Also exporting geometries to json and read them from there seems to do the trick.

0 Kudos
AnttiKajanus1
Regular Contributor II

Hi Mark,

How did you create the geodatabase? What tools were used etc? If you don't want to share that information publicly, please send it directly to me to akajanus-at-esri.com.

cheers,

Antti

0 Kudos