ArcGIS Runtime 100.2.1 does not work with Xamarin Forms and Android 4.2.2

1556
13
Jump to solution
03-21-2018 06:23 AM
SandeepKuniel1
New Contributor III

We have been trying to put the basic .net sample on the Leica Zeno 20 UMTS having android Android 4.2.2.
Trying to open a simple "Display Map" page....gives this error.
System.NotSupportedException: Could not activate JNI Handle 0x2b00025 (key_handle 0x4113f7e8) of Java type 'md525ae7a30145b6936c079fc7426298397/DisplayMap' as managed type 'ArcGISRuntimeXamarin.Samples.DisplayMap.DisplayMap'.

We have even tried on the emulator with android 4.2.2.

Any help would be appreciated!

 

0 Kudos
13 Replies
dotMorten_esri
Esri Frequent Contributor

OK I tracked down the bug, and will manifests itself on devices at API Level 16 and Level 17 (ie v4.2 and down).

Luckily I have a workaround for you. In the Application constructor add the following line:

 Java.Lang.JavaSystem.LoadLibrary("runtimecore");

Let me know if that works for you or not.

View solution in original post

SandeepKuniel1
New Contributor III

Wonderful Morten, thank you for the workaround, it works and our app also works nicely on the device.

dotMorten_esri
Esri Frequent Contributor

Btw, I just want to point you to the deprecation notice in the v100.2.1 release notes: https://developers.arcgis.com/net/latest/wpf/guide/release-notes.htm

Specifically this part: "Xamarin.Android development for API levels 15 (Android 4.0.3-4.0.4), 16 (Android 4.1-4.1.1), 17 (Android 4.2 - 4.2.2), and 18 (Android 4.3). With the 100.3 release, the minimum will be API level 19 (Android 4.4)."

I've logged the bug, but since we're dropping support for the levels that the issue will manifests itself on, we'll probably not add the fix to the SDK.

0 Kudos
SandeepKuniel1
New Contributor III

Yup, we are aware of this, unfortunately cannot do anything about it until we get an upgrade from Leica.

Thank you for the help. 

0 Kudos