Legend cache issue

1749
1
08-18-2011 09:19 AM
KomalFernandes
New Contributor
I am using ArcScripts http://arcscripts.esri.com/details.asp?dbid=16999 by Iain Campion to generate legend in JavaScript application.

The application works well and it generates legend only once. All subsequent request simply response by sending old image URL. The directory in which it generates is cleaned by ArcGIS server process so the application displays legend Label with brocken image URL.

I am using ArcServer 9.3.1 and for reason beyond my control can't upgrade.

So question is can I change location where legend image is generated. By default it grabs Output directory of map service. Is there any way to force application to send request every time. Please let me know if I am missing anyting.

Thanks,

Komal
0 Kudos
1 Reply
RaviNarayanan
Esri Contributor
Hi,

Iain has indicated here that his code supports returning base64 encoded images. can you use the base64 images instead of the URL? If the URL is use the client should cache the images so that it does not rely on the images to be present on the servers output directory.


Gidday, I've extending this good work by SharpGIS to include base64 encoded images so that the legends are done via text so caching not an issue. really fast. (same as the new ags online - they have a service based off this ) also added in the ability to send more than one map service at a time so you only need to make one request to the rest service - or still multiple times if you wish too.
0 Kudos