Can Add in developed in 2.3 works for 2.4

436
8
07-16-2019 11:45 AM
NareshNagandla
New Contributor II

HI,

I would like to know if I develop an Add-in using Pro SDK .NET framework in ArcGIS Pro 2.3.  

Can I consume the same add-in for all latest versions as well like 2.4??  

It should not be having any issues as per my knowledge. But do please let me know if any one else has seen the issues. 

Tags (1)
0 Kudos
8 Replies
LaurenBoyd
Esri Contributor

Hi Naresh Nagandla‌ -

You are correct! Add-ins and configurations are forwards compatible across all minor versions of ArcGIS Pro. Add-ins and configurations are not forward compatible across major versions (eg 2.x, 3.x, etc). You have to make a few changes to the add-in or configuration to get it to work across major versions.

You can find more information on this in the ArcGIS Pro SDK documentation on the GitHub Site: ProConcepts Advanced Topics .

Good luck with your ArcGIS Pro SDK development!

0 Kudos
ModyBuchbinder
Esri Regular Contributor

I have a problem with this.

My SDK automatically updated to 2.4 but when I build and work with pro 2.3 everything is fine.

Then I upgraded my machine only to pro 2.4

After I build the addin, when I install it on 2.3 machines (no SDK) I can see the addin in pro but when a press a button that shows Dockpane - nothing happen.

0 Kudos
NareshNagandla
New Contributor II

Hello Mody Buchbinder

Is it because you are trying to deploy the Add-in built in 2.4 and adding it in 2.3 installed machines??

Add-ins and configurations are forwards compatible across all minor versions of ArcGIS Pro.  In this case you are trying backward compatibility.

My question is how come SDK automatically updated to 2.4??

0 Kudos
CharlesMacleod
Esri Regular Contributor
0 Kudos
NareshNagandla
New Contributor II

HI,

That link only tell about below topics:

  • Install ArcGIS Pro SDK for .NET<https://github.com/Esri/arcgis-pro-sdk/wiki/ProGuide-Installation-and-Upgrade#install-arcgis-pro-sdk-for-net>

  • Upgrade ArcGIS Pro SDK for .NET<https://github.com/Esri/arcgis-pro-sdk/wiki/ProGuide-Installation-and-Upgrade#upgrade-arcgis-pro-sdk-for-net>

  • Uninstall ArcGIS Pro SDK for .NET<https://github.com/Esri/arcgis-pro-sdk/wiki/ProGuide-Installation-and-Upgrade#uninstall-arcgis-pro-sdk-for-net>

  • Distribute ArcGIS Pro SDK for .NET using a private gallery<https://github.com/Esri/arcgis-pro-sdk/wiki/ProGuide-Installation-and-Upgrade#distribute-arcgis-pro-sdk-for-net-using-a-private-gallery>

It didn’t mention anything about if lower version Add-in’s will work for Future versions of ArcGIS Pro.

Regards,

Naresh

0 Kudos
CharlesMacleod
Esri Regular Contributor

I was answering this:

>>My question is how come SDK automatically updated to 2.4??<<

0 Kudos
NareshNagandla
New Contributor II

OK Great Thank You!!

0 Kudos
ModyBuchbinder
Esri Regular Contributor

This is how it looks in VS. This is the default.

0 Kudos