Select to view content in your preferred language

XY to Line doesn't curve

693
7
06-08-2023 01:13 PM
Labels (1)
DiDeng
by
New Contributor II

I am trying to create a map with XY points and curves that connect the points. I used XY to Line, but the lines don't curve at all even when I changed the symbology of it from straight to curve. I want to achieve something like this that I did in R. Straight lines just don't look good with so many points.

DiDeng_0-1686255146754.png

 

0 Kudos
7 Replies
DiDeng
by
New Contributor II

Right now it looks like this:

DiDeng_0-1686255346617.png

 

0 Kudos
DanPatterson
MVP Esteemed Contributor

XY To Line (Data Management)—ArcGIS Pro | Documentation

did you choose geodesic? or what option for the connecting lines?


... sort of retired...
0 Kudos
DiDeng
by
New Contributor II

I used geodesic. The region is small, so the geodesic will look like a straight line.

0 Kudos
DanPatterson
MVP Esteemed Contributor

So that is the result then .... unless you are outputting to a shapefile, then you will never get curves (since shapefiles don't support them.) 

Perhaps try other options if you need visual curvature


... sort of retired...
0 Kudos
DiDeng
by
New Contributor II

I tried "great circle", but it is the same. Choosing any of the line types leads to the exact same result.  Are there other settings to achieve this?

DiDeng_0-1686752564012.png

 

0 Kudos
DiDeng
by
New Contributor II

DiDeng_1-1686752776976.png

This is "Rhumb line". Same thing here, nothing is changed.

0 Kudos
DiDeng
by
New Contributor II

"Normal section" same. These are all the options it has.

DiDeng_2-1686753052933.png

 

0 Kudos