Webmap setting (tile layer with popup configured from feature service) not respected in Pro

377
8
11-22-2021 11:46 AM
Labels (3)
DanielleKulas
Occasional Contributor III

I have a webmap that displays several tiled layers, each of which has a popup enabled. The popups point to analogous feature service layers and they works great in ArcGIS Online. When I open the same webmap in Pro, nothing appears when I identify on those same tiled layers, even though when I right click on the layer in the Contents pane, it appears that the popups are enabled because I see a 'disable popup' option. Nothing seems to happen when I disable and re-enable them. I am on Pro version 2.9.0 Any ideas what could be happening?

DanielleKulas_0-1637610248304.png

 

0 Kudos
8 Replies
ABishop
Regular Contributor III

Hello Danielle,

Pop-ups configured in AGOL are not the same as pop-ups configured in ArcGIS Pro desktop.  Unless you are adding the data as a feature service URL into ArcGIS Pro desktop?

Amanda Bishop, GISP
0 Kudos
DanielleKulas
Occasional Contributor III

Hi Amanda,

Thanks for your quick reply. The data in the webmap are all hosted tiled services- is there a way to configure the popup in Pro on tiled layers to point to the attributes in a feature service? We were trying to avoid adding the feature service to Pro for display purposes because it's a monster dataset. When I right click on the tiled layer in the contents pane, 'Configure popups' remains grayed out.

Danielle

0 Kudos
ABishop
Regular Contributor III

I would configure the pop-ups in AGOL and display them there.  Is there a reason you want to use them in ArcGIS Pro desktop?

Amanda Bishop, GISP
0 Kudos
DanielleKulas
Occasional Contributor III

We were hoping for flexibility/variation in methods for end users to view a publically accessible dataset, and have been pointing folks to ArcGIS Online as well as Pro. To me not being able to configure the popup in the same way as the webmap seems like a limitation.

0 Kudos
ABishop
Regular Contributor III

Instead of adding the Web Map to ArcGIS Pro, have you tried adding the individual feature services, configuring the pop-ups the way you want to see them in Pro, and then saving and sharing that project?

Amanda Bishop, GISP
0 Kudos
DanielleKulas
Occasional Contributor III

I did- I created a new map, added a tile layer from ArcGIS Online, and when I click 'Enable Popup,' the option to configure it is grayed out. 

DanielleKulas_0-1637616920556.png

 

0 Kudos
ABishop
Regular Contributor III

Its probably because you don't own the service?

Amanda Bishop, GISP
0 Kudos
DanielleKulas
Occasional Contributor III

I probably should have included this info earlier on but alas, the owner of the content is having the same issue. I'm also the administrator for our ArcGIS Online Org so I don't think it's a permissions thing unfortunately.

0 Kudos