Updating workspace data sources fails (for most of the features)

267
3
11-16-2021 08:37 AM
no33mis
New Contributor II

Dear Community,

I have a map with a bunch of features (~100). Since we work on two different enviornments, I have to migrate the data sources from one to the other, which would be extremely tedious by adding a new path to each feature. 

I was hoping to update the data sources on the Workspace view, where I am able to provide the two data sources from the new environment that contain all of the features. Unfortunately it would only update 3 features, and leave the others unchanged. 

no33mis_4-1637080476711.png

This is a screenshot from the workspace view.

I though that maybe it would handle features within feature classes differently, which is not the case. For instance, there are two features within the same feature class (both simple polygons) - one got updated, the other one didn't.

no33mis_2-1637080371958.png

And a screenshot from the item view.

All of the items do exist in both databases, and the migration works perfectly fine in ArcCatalog. We are moving more and more towards ArcGIS Pro, but are surprised by the issues we face with simple tasks we require for our daily work.

I cannot find more information on why the the items failed to update (is there an additional log?). Any ideas what could cause the problem?

Many thanks.

0 Kudos
3 Replies
MichaelVolz
Esteemed Contributor

What version of Pro are you working in?

Is this an enterprise geodatabase?  If so is it Oracle, SQL Server, other?

Is the data in all standalone feature classes and table or in feature datasets or combination?

0 Kudos
no33mis
New Contributor II

Dear Michael,

Thanks for your response.

We work on ArcGIS Pro 2.8.3 and MS SQL Server, connection via SDE-Files.

We have a combination of data, the spatial features are within feature datasets, for instance we have a dataset "playground" that contains playground polygons and playground equipment as points. Tables are outside of feature datasets.  

This is our architecture for many years, in which we have used ArcCatalog for data management, including data source update.

0 Kudos
MichaelVolz
Esteemed Contributor

I was not implying that there is anything wrong with your setup, its just that the Update Data Sources on the Workspace Mode has had some bugs associated with it in terms of data in feature datasets. These bugs were occurring with enterprise databases in Pro 2.8.x but ESRI has fixed the bugs at Pro 2.9.  I would suggest upgrading to Pro 2.9 (if you can) and try using the Update Data Sources on the Workspace Mode again and see if you get better results.

0 Kudos