Select to view content in your preferred language

unable to delete own feature from feature service inside ArcGIS Pro

554
2
Jump to solution
06-05-2023 08:49 AM
Labels (2)
KonstantinNagornyuk1
New Contributor III

We have ArcGIS Enterprise 10.9.1 (base deployment), all patches were installed. Editable feature service was published from enterprise geodatabase (PostgreSQL). 

We try to use ownership based access control and edit feature service inside ArcGIS Pro (3.0). It works fine in MapViewer but unfortunately doesn't work for Pro. For example, we cretae feature, save it and then the same user tries to delete that feature, but get the message below. We see the same behavior for hosted feature service as well. 

KonstantinNagornyuk1_0-1685979208813.png

Any suggestions? Thank you in advance.

 

0 Kudos
1 Solution

Accepted Solutions
Robert_LeClair
Esri Notable Contributor

This appears to be BUG-000153191 - When 'Editors can only edit their own features (requires editor tracking)' is enabled, the data in a group cannot be edited by the creator of the feature in ArcGIS Pro."  Currently, the only workaround is edit the data in ArcGIS Online/ArcGIS Enterprise.  Is the web layer stored in a group?

View solution in original post

2 Replies
Robert_LeClair
Esri Notable Contributor

This appears to be BUG-000153191 - When 'Editors can only edit their own features (requires editor tracking)' is enabled, the data in a group cannot be edited by the creator of the feature in ArcGIS Pro."  Currently, the only workaround is edit the data in ArcGIS Online/ArcGIS Enterprise.  Is the web layer stored in a group?

KonstantinNagornyuk1
New Contributor III

Thank you very much! web layer was stored in a group. Now I share it for organization and editing is working fine in ArcGIS Pro.